Location bar and search bar text sizes are too small on Windows

VERIFIED FIXED in Firefox 55

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: daleharvey, Assigned: daleharvey)

Tracking

unspecified
Firefox 55
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified)

Details

(Whiteboard: [photon-visual][p1])

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

2 years ago
No description provided.
Assignee

Comment 1

2 years ago
My mistake, I put the existing font-size inside a photon ifdef
Assignee: nobody → dale
Status: NEW → ASSIGNED
Iteration: --- → 55.6 - May 29
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [photon-visual]
Assignee

Comment 2

2 years ago
Posted patch 1365906-1.patch (obsolete) — Splinter Review
We want 1.15em in photon, thats what it was originally so I left it alone and ifdef'd around it, but this was already inside a larger ifdef that I missed, so duplicated the font-size so it applies to photon as well
Comment on attachment 8868989 [details] [diff] [review]
1365906-1.patch

>+@media (-moz-os-version: windows-win10) {
>+  #urlbar,
>+  .searchbar-textbox {
>+    font-size: 1.15em;
>+  }
>+}

I think we want this regardless of the Windows version.
Flags: qe-verify? → qe-verify+
OS: Unspecified → Windows
Summary: Windows font is too small → Location bar and search bar text sizes are too small on Windows
Whiteboard: [photon-visual] → [photon-visual][p1]
QA Contact: brindusa.tot
Assignee

Comment 4

2 years ago
Yeh I was thinking about setting it on all platforms, just being a little conservative using the current rules, cheers
Attachment #8868999 - Flags: review?(dao+bmo)
Assignee

Updated

2 years ago
Attachment #8868989 - Attachment is obsolete: true
Attachment #8868999 - Flags: review?(dao+bmo) → review+

Comment 5

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/57b76ce88152
Increase URL bar and the search bar text size for all Windows versions. r=dao

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/57b76ce88152
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55

Comment 7

2 years ago
(In reply to Dale Harvey (:daleharvey) from comment #4)
> Created attachment 8868999 [details] [diff] [review]
> 1365906-2.patch
> 
> Yeh I was thinking about setting it on all platforms, just being a little
> conservative using the current rules, cheers

I like the small font :(

and pref to get it back? please :(
Flags: needinfo?(dale)

Comment 8

2 years ago
Please provide an in built option to revert back to small fonts,
why do compact themes have vertical padding so much?
where to file bug to remove it or is it intentional in which case it's eating up Precious space for content :(
(In reply to Sami from comment #7)
> and pref to get it back? please :(

We're not going to add a pref for this.

(In reply to Sami from comment #8)
> Please provide an in built option to revert back to small fonts,
> why do compact themes have vertical padding so much?
> where to file bug to remove it or is it intentional in which case it's
> eating up Precious space for content :(

See bug 1350210 for compact mode support.
Flags: needinfo?(dale)

Comment 10

2 years ago
I have reproduced this bug with Nightly 55.0a1 (2017-05-18) on Windows 8.1 , 64 Bit ! 

This bug's fix is Verified with latest Nightly 55.0a1 !

Build ID      20170519030205
User Agent    Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

[testday-20170519]
(In reply to Sajedul Islam from comment #10)
> I have reproduced this bug with Nightly 55.0a1 (2017-05-18) on Windows 8.1 ,
> 64 Bit ! 
> 
> This bug's fix is Verified with latest Nightly 55.0a1 !

Thanks.

(In reply to Dão Gottwald [::dao] from comment #9)
> (In reply to Sami from comment #8)
> > Please provide an in built option to revert back to small fonts,
> > why do compact themes have vertical padding so much?
> > where to file bug to remove it or is it intentional in which case it's
> > eating up Precious space for content :(
> 
> See bug 1350210 for compact mode support.

I've filed bug 1366346 specifically for the location / search bar text size.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

2 years ago
Depends on: 1366519
Blocks: 1352366
No longer blocks: photon-visual
Duplicate of this bug: 1186562
You need to log in before you can comment on or make changes to this bug.