[e10s] changing selectbox in iframe makes content in outer frame unclickable

RESOLVED DUPLICATE of bug 1351072

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED DUPLICATE of bug 1351072
5 months ago
4 months ago

People

(Reporter: micha.hastrich, Unassigned)

Tracking

(Blocks: 1 bug, {regression, testcase})

53 Branch
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox53 wontfix, firefox54+ wontfix, firefox55+ fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

136 bytes, text/html
Details
291 bytes, text/html
Details
(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

For a simplified version you need a html page with a button and an iframe. In the iframe you need a <select>. If you change the value of the select it is not possible to click in the outside frame. You need to do two clicks - the first one actives the outer frame an the second click aktivates the onclick action.

I will provide an example as an attachment.


Actual results:

The Button in the outer Frame was not clickable - it didn't even render the "cursor:pointer" which it has in its CSS. Onclick action is not performaed on click. After clicking the button or clicking anywhere else in the outer frame everything is back to normal - you get the pointer and the onclick action is performed.

After cleaning up firefox it works again.
We tried this on different OS and workstations (Win7, Win10, MacOS) and we were able to reproduce it on every system.


Expected results:

After selecting a new value in the selectbox the cursor:pointer over the button in the outer frame should have been rendered and it should have been possible to click the button and activate its onclick action.
(Reporter)

Comment 1

5 months ago
Created attachment 8869036 [details]
firefoxbug.html
(Reporter)

Comment 2

5 months ago
Created attachment 8869037 [details]
iframe.html

Comment 3

5 months ago
Created attachment 8869056 [details]
firefoxbug.html
Attachment #8869036 - Attachment is obsolete: true

Comment 4

5 months ago
Another bug with e10s and <select>.
Blocks: 1154677
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Summary: changing selectbox in iframe makes content in outer frame unclickable → [e10s] changing selectbox in iframe makes content in outer frame unclickable
Comment hidden (off-topic)
Comment hidden (off-topic)

Comment 7

5 months ago
Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a925f48bcc829d19b1c9f35d15c5a5f03b23b91c&tochange=32bde324c727a46b0409bc174ec33ca2d77bdc1a

It could be:
Neil Deakin — Bug 1314647, clear active state of select on mouseup, r=mconley

As Neil is not available, could you find someone able to work on this recent regression, please.
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
tracking-firefox54: --- → ?
tracking-firefox55: --- → ?
Ever confirmed: true
Flags: needinfo?(mconley)
Keywords: regression, testcase
Track 54+/55+ as regression.
tracking-firefox54: ? → +
tracking-firefox55: ? → +
I'm really swamped with Quantum Flow and Photon stuff. overholt, we were talking about finding someone to take these <select> bugs... did you have someone in mind?
Flags: needinfo?(mconley) → needinfo?(overholt)
Too late for 53.
status-firefox53: affected → wontfix
(In reply to Mike Conley (:mconley) from comment #9)
> I'm really swamped with Quantum Flow and Photon stuff. overholt, we were
> talking about finding someone to take these <select> bugs... did you have
> someone in mind?

I took this to email.
Flags: needinfo?(overholt)
Firefox seems the only browser with this issue.
HsinYi, it's likely an issue about form state control, would you like to assign someone to pick it up?
Flags: needinfo?(htsai)
Priority: -- → P2
Too late for 54. Mark 54 won't fix.
status-firefox54: affected → wontfix
(In reply to Astley Chen [:astley] (UTC+8) from comment #12)
> Firefox seems the only browser with this issue.
> HsinYi, it's likely an issue about form state control, would you like to
> assign someone to pick it up?

Sure! Ben, please help this :)
Flags: needinfo?(htsai) → needinfo?(btian)
Likely a dupe of bug 1351072.
Let's see if the patch in bug 1351072 could fix this issue or not.
See Also: → bug 1351072
By applying the patch in bug 1351072. the symptom in this bug is fixed.
Let's keep it up in bug 1351072 and close this one.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1351072

Comment 17

4 months ago
Thanks Astley:) Clear my ni?
Flags: needinfo?(btian)
Fixed in 55 in bug 1351072.
status-firefox55: affected → fixed
You need to log in before you can comment on or make changes to this bug.