[traceback] webapp docker container is failing on collectstatic

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When running the webapp service in Docker ("docker-compose up webapp") or running the tests ("make dockertest"), it fails when running "python manage.py collectstatic".

Traceback:

Copying '/app/webapp-django/crashstats/topcrashers/static/topcrashers/js/topcrashers.js'
Traceback (most recent call last):
  File "manage.py", line 12, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 354, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 346, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 394, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 445, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python2.7/site-packages/django/contrib/staticfiles/management/commands/collectstatic.py", line 168, in handle
    collected = self.collect()
  File "/usr/local/lib/python2.7/site-packages/django/contrib/staticfiles/management/commands/collectstatic.py", line 114, in collect
    for original_path, processed_path, processed in processor:
  File "/usr/local/lib/python2.7/site-packages/pipeline/storage.py", line 26, in post_process
    packager.pack_stylesheets(package)
  File "/usr/local/lib/python2.7/site-packages/pipeline/packager.py", line 96, in pack_stylesheets
    variant=package.variant, **kwargs)
  File "/usr/local/lib/python2.7/site-packages/pipeline/packager.py", line 106, in pack
    content = compress(paths, **kwargs)
  File "/usr/local/lib/python2.7/site-packages/pipeline/compressors/__init__.py", line 78, in compress_css
    css = getattr(compressor(verbose=self.verbose), 'compress_css')(css)
  File "/usr/local/lib/python2.7/site-packages/pipeline/compressors/cssmin.py", line 10, in compress_css
    return self.execute_command(command, css)
  File "/usr/local/lib/python2.7/site-packages/pipeline/compressors/__init__.py", line 247, in execute_command
    stdin=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/local/lib/python2.7/subprocess.py", line 390, in __init__
    errread, errwrite)
  File "/usr/local/lib/python2.7/subprocess.py", line 1024, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Makefile:64: recipe for target 'dockertest' failed


Pretty sure the problem is that the django-pipeline can't find lessc and friends.
Assignee: nobody → willkg
Status: NEW → ASSIGNED

Comment 2

a year ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/ab2e99c9aa3ea47ca39daee7479a1aea67820ff4
Fixes bug #1366016 - Fix collectstatic for webapp (#3782)

This fixes collectstatic when building the image as well as when running tests
and running the webapp service.

This also fixes running the tests.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.