[RFE] Automatic Session Keep Alive?

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: dothebart, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Most Internet-sites work with session Time-outs.
I've often suffered the happening that I entered something, the entered wasn't
valid, until I found out what was wrong, the server terminated the session, 
And one has do do it all over again.
Here my Sugestion: 
Why not have a "keepalive" button, that does a head Request to the actual
address every n Seconds (there could be a dialog with the time) which would the
Server make think that I'm still working on it, while getting the needed
Circumstances to proceed my work?

Comment 1

17 years ago
hmm... interesting suggestion.  the real question is what is the server using to
determine session timeout... time since a particular cookie was last sent? 
probably.  at any rate, no time for this bug now -> future.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Automatic Session Keep Alive? → [RFE] Automatic Session Keep Alive?
Target Milestone: --- → Future
(Reporter)

Comment 2

17 years ago
usualy the server keeps a number of active sessions, and cleans them (and their
data) up if a given amount of time is passed, the session-data is thrown away.
(this is either practice if one uses cookies or query-string)

Comment 3

13 years ago
-> default owner
Assignee: darin → nobody
QA Contact: tever → networking.http
Target Milestone: Future → ---
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.