Iframes now auto-scale SVG content to fit, unlike every other browser

RESOLVED DUPLICATE of bug 1342800

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 1342800
5 months ago
5 months ago

People

(Reporter: Stephen Hicks, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.47 Safari/537.36

Steps to reproduce:

echo '<iframe src="rect.svg"></iframe>' > /tmp/rect.html
cat > /tmp/rect.svg <<EOF
<?xml version="1.0" encoding="utf-8"?>
<svg xmlns="http://www.w3.org/2000/svg" version="1.1" baseProfile="full"
    width="400px" height="400px" viewBox="0 0 100 100">
  <rect id="rect" width="50" height="50" fill="blue"/>
</svg>
EOF
firefox file:///tmp/rect.html


Actual results:

As of Firefox 53, the iframe has its content scaled (down) to fit.  If the width and height are smaller (e.g. 100px) it will scale up instead.


Expected results:

The iframe content should be unscaled, with scroll bars if the iframe is too small for the content.  This is the behavior in earlier versions of Firefox and in all other desktop browsers (Chrome, Edge, and Safari).  There was no mention of any change in behavior in the changelogs (as far as I could find).

Updated

5 months ago
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1342800
You need to log in before you can comment on or make changes to this bug.