Intermittent browser/base/content/test/tabs/browser_new_web_tab_in_file_process_pref.js | Test timed out -

RESOLVED FIXED in Firefox -esr60

Status

()

defect
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: intermittent-bug-filer, Assigned: bobowen)

Tracking

({intermittent-failure, regression})

unspecified
mozilla63
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 fixed, firefox62 wontfix, firefox63 fixed)

Details

(Whiteboard: [stockwell fixed:timing])

Attachments

(2 attachments)

https://wiki.mozilla.org/Bugmasters#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: REOPENED → RESOLVED
Closed: 2 years agoLast year
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
[::dao:

Hi,
This bug had a spike in the last 7 days.

Can you please take a look?
Flags: needinfo?(dao+bmo)
Whiteboard: [stockwell needswork]
(In reply to Dorel Luca [:dluca] from comment #43)
> [::dao:
> 
> Hi,
> This bug had a spike in the last 7 days.
> 
> Can you please take a look?

Do you have a regression range?

It looks like this has originally started failing intermittently after bug 1351358 landed. Bob, can you take a look?
Blocks: 1351358
Component: Tabbed Browser → DOM: Content Processes
Flags: needinfo?(dluca)
Flags: needinfo?(dao+bmo)
Flags: needinfo?(bobowencode)
Product: Firefox → Core
Flags: needinfo?(dluca)
I'm afraid I can't see what's going wrong here.
There are some errors from nsIURIMutator.h, which might be related.
It's weird that this seems to be almost exclusively on Mac.
I'm guessing it's a timing issue, but a regression range for the recent spike might help.
Flags: needinfo?(bobowencode)
There are 54 failures in the last 7 days.
Most of them (44 failures) are on "osx-10-10" 

From what I can see, it started to spike from https://hg.mozilla.org/integration/autoland/rev/3f0325c0b307be193b5549f6bd98881a2d70a371

Latest log link: https://treeherder.mozilla.org/logviewer.html#?job_id=195421135&repo=mozilla-inbound&lineNumber=5458

18:27:54     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/tabs/browser_new_web_tab_in_file_process_pref.js | Test timed out - 
18:27:54     INFO - GECKO(1995) | [Parent 1995, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file /builds/worker/workspace/build/src/obj-firefox/dist/include/nsIURIMutator.h, line 450
18:27:54     INFO - GECKO(1995) | [Parent 1995, Main Thread] WARNING: NS_ENSURE_SUCCESS(mStatus, *this) failed with result 0x804B000A: file /builds/worker/workspace/build/src/obj-firefox/dist/include/nsIURIMutator.h, line 605
18:27:54     INFO - GECKO(1995) | [Parent 1995, Main Thread] WARNING: NS_ENSURE_SUCCESS(mStatus, mStatus) failed with result 0x804B000A: file /builds/worker/workspace/build/src/obj-firefox/dist/include/nsIURIMutator.h, line 644
18:27:54     INFO - GECKO(1995) | MEMORY STAT | vsize 4464MB | residentFast 426MB | heapAllocated 105MB
18:27:54     INFO - TEST-OK | browser/base/content/test/tabs/browser_new_web_tab_in_file_process_pref.js | took 90197ms

:bobowen , can you please take a look?
Flags: needinfo?(bobowencode)
Whiteboard: [stockwell unknown] → [stockwell needswork:owner]
I'm in the process of trying to track down what caused the spike in the hope that it might shed some light on the original problem.
:bobowen , I think we should disable it on OSX until you`ll find a solution
Attachment #9004443 - Flags: review?(jmaher)
Attachment #9004443 - Flags: review?(jmaher) → review+
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
(In reply to Narcis Beleuzu [:NarcisB] from comment #56)
> Created attachment 9004443 [details] [diff] [review]
> Disable on OSX debug
> 
> :bobowen , I think we should disable it on OSX until you`ll find a solution

Yeah, I agree.
Although at the moment, I think that will not be anytime soon.

I've tried to use pushes around when this seemed to get worse to try and figure something out, but it's very difficult to see which push might have caused the regression.
So, I'm still no clearer as to why this is failing and why it has got worse recently, sorry.

I don't think having this run on OSX matters too much.
The only thing is that it might point to an issue on OSX, did we get other similar increases on OSX oranges around the same time?
Flags: needinfo?(bobowencode) → needinfo?(nbeleuzu)
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b6d7a77d5109
Disable browser_new_web_tab_in_file_process_pref.js on OSX-debug for frequent failures. r=jmaher
Keywords: checkin-needed
:bobowen , I`m not aware of an increase in number of failures on OSX
Will check and reply if I`ll find something
Flags: needinfo?(nbeleuzu)
(In reply to Narcis Beleuzu [:NarcisB] from comment #62)
> Will check and reply if I`ll find something

Thanks, looks like mconley might have found the issue here.
I'll have a try push running once I can persuade python to run the test locally.
Assignee: nobody → bobowencode
Status: REOPENED → ASSIGNED
Comment on attachment 9005185 [details] [diff] [review]
Wait for the correct URLs to have loaded in browser_new_web_tab_in_file_process_pref.js

Review of attachment 9005185 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9005185 - Flags: review?(mconley) → review+
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3e4f7e87f835
Wait for the correct URLs to have loaded in browser_new_web_tab_in_file_process_pref.js. r=mconley
No new occurrences in over a week.
Thanks again mconley!
Status: ASSIGNED → RESOLVED
Closed: Last year11 months ago
Keywords: leave-open
Resolution: --- → FIXED
Whiteboard: [stockwell disabled]
Whiteboard: [stockwell fixed]
Whiteboard: [stockwell fixed] → [stockwell fixed:timing]
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.