Error in mozilla <-> jre1.4.0

RESOLVED FIXED in mozilla1.0

Status

Core Graveyard
Java: OJI
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: Søren Holm, Assigned: Joshua Xia)

Tracking

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Mozilla 2002040908 locks up accesing http://www.al-netbank.dk
I am runing Debian Unstable, jre 1.4.0

Mozilla outputs this in konsole
**************** SERVER ERROR **************
SecureCallStaticMethod: bad method
**************** ************ **************

Comment 1

16 years ago
This is not a JSS bug. Please assign this bug to the correct component when you
reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Updated

16 years ago
Component: Library → OJI
Product: JSS → Browser
Target Milestone: --- → mozilla1.0
Version: 3.0 → other
(Reporter)

Comment 2

16 years ago
Component & product was wrong at first
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

16 years ago
Reassign to OJI owner.
Assignee: nicolson → joe.chou

Comment 4

16 years ago
Confirming crash. Recent trunk build and jre 1.4rc (on both redhat 7.1 and 7.2)

However, i did not reported message. 
For me situation is different - i granted permissions and classes are loaded
but applet does not start. Indeed browser abort with message:
  Assertion failure: 0, at jsj_JSObject.c:811

I will check whenever this OJI or Liveconnect/JS problem.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
Here is stacktrace:

#0  0x40609a01 in __kill () from /lib/i686/libc.so.6
#1  0x403285bb in raise (sig=6) at signals.c:65
#2  0x4060af82 in abort () at ../sysdeps/generic/abort.c:88
#3  0x4011a527 in JS_Assert () at jsutil.c:173
#4  0x4006742d in jsj_exit_js (cx=0x435af490, jsj_env=0x43c68000, 
    original_reporter=0x4154ddb0 <NS_ScriptErrorReporter(JSContext *, char const
*, JSErrorReport *)>) at jsj_JSObject.c:811
#5  0x40075bc4 in nsCLiveconnect::GetWindow (this=0x43c68bc8, jEnv=0x43c3ea38, 
    pJavaObject=0x432e0b2c, principalsArray=0x0, numPrincipals=0, 
    securitySupports=0x43c696f8, pobj=0xbffff218) at nsCLiveconnect.cpp:603
#6  0x41da37e3 in JSGetNativeJSObject ()
   from
/usr/local/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so#7 
0x41da3f90 in JSHandler ()
   from
/usr/local/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so#8 
0x41d99201 in JavaVM5::ProcessSpontaneousQueue ()
   from
/usr/local/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so#9 
0x41d982b7 in spont_queue_processor ()
   from
/usr/local/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so#10
0x41d94f56 in QueueRunnable::Run ()
---Type <return> to continue, or q <return> to quit---
   from
/usr/local/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so#11
0x41c5da8a in handleRunnableEvent (aEvent=0x8396850)
    at nsJVMManager.cpp:299
#12 0x4022179c in PL_HandleEvent (self=0x8396850) at plevent.c:596
#13 0x402215b1 in PL_ProcessPendingEvents (self=0x80f8c30) at plevent.c:526
#14 0x402237e2 in nsEventQueueImpl::ProcessPendingEvents (this=0x80a1ac8)
    at nsEventQueue.cpp:388
#15 0x40b060f4 in event_processor_callback (data=0x80a1ac8, source=6, 
    condition=GDK_INPUT_READ) at nsAppShell.cpp:184
#16 0x40b05cd3 in our_gdk_io_invoke (source=0x8113928, condition=G_IO_IN, 
    data=0x8113918) at nsAppShell.cpp:77
#17 0x404aff9e in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#18 0x404b1773 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#19 0x404b1d39 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#20 0x404b1eec in g_main_run () from /usr/lib/libglib-1.2.so.0
#21 0x403cc333 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#22 0x40b06769 in nsAppShell::Run (this=0x8117848) at nsAppShell.cpp:364
#23 0x40aa8ee1 in nsAppShellService::Run (this=0x811fbb8)
    at nsAppShellService.cpp:308
#24 0x0805cd4d in main1 (argc=2, argv=0xbffff764, nativeApp=0x0)
    at nsAppRunner.cpp:1415

Comment 6

16 years ago
This applet does JSObject.getWindow() inside the init()

bug  112434, bug 124053 and bug 120727 may be related.
(Reporter)

Comment 7

16 years ago
Aparently the applet at http://www.al-netbank.dk is now functional,
and since the bank has not changes anything since 2002-04-18
the bug regarding this applet must have been resolved.
(Assignee)

Comment 8

15 years ago
reassign to me
Assignee: joe.chou → joshua.xia
(Assignee)

Comment 9

15 years ago
can't reproduce
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
(Reporter)

Comment 10

7 years ago
Works for me now. It's has been 8 years, and it has problably been fixed for a long time.
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.