Closed Bug 1366221 Opened 3 years ago Closed 3 years ago

Stylo: Build error: static_assert failed "DOM size changed" on OSX

Categories

(Core :: CSS Parsing and Computation, defect)

55 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1365954

People

(Reporter: jonco, Unassigned)

References

Details

I'm getting local build errors on OSX related to the element size asserts added in bug 1363375:

/Users/jon/work/modules/dom/base/Element.cpp:183:1: error: static_assert failed "DOM size changed"
ASSERT_ELEMENT_SIZE(Element, 120);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/Users/jon/work/modules/dom/base/Element.cpp:178:3: note: expanded from macro 'ASSERT_ELEMENT_SIZE'
  static_assert(sizeof(void*) != 8 || a == b, "DOM size changed"); \
  ^             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/Users/jon/work/modules/dom/base/Element.cpp:183:1: note: in instantiation of template class 'CheckElementSize<128, 120>' requested here
/Users/jon/work/modules/dom/base/Element.cpp:180:69: note: expanded from macro 'ASSERT_ELEMENT_SIZE'
Check##type##Size<sizeof(type), opt_size + EXTRA_DOM_ELEMENT_BYTES> g##type##CES;
                                                                    ^
<scratch space>:38:1: note: expanded from here
gElementCES
^

OSX version: 10.12.4

$ /usr/bin/clang --version
Apple LLVM version 8.1.0 (clang-802.0.42)
Target: x86_64-apple-darwin16.5.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

$ cat opt-build/mozconfig 
. $topsrcdir/browser/config/mozconfig
CC='clang'
CXX='clang++'
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/opt-build
mk_add_options MOZ_MAKE_FLAGS="-s -j8"
ac_add_options --with-ccache=/usr/local/bin/ccache
mk_add_options AUTOCONF=/usr/local/bin/autoconf213
mk_add_options AUTOCLOBBER=1
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --disable-profiling
Summary: Build error: static_assert failed "DOM size changed" on OSX → Stylo: Build error: static_assert failed "DOM size changed" on OSX
This is presumably because of --disable-profiling. This should be fixed with bug 1365954.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365954
You need to log in before you can comment on or make changes to this bug.