5.95% sessionrestore (osx-10-10) regression on push 18c74031bd89d38e7663dc7979d6fc8010b69867 (Wed May 17 2017)

RESOLVED DUPLICATE of bug 1364477

Status

()

Toolkit
WebExtensions: Frontend
P1
normal
RESOLVED DUPLICATE of bug 1364477
3 months ago
3 months ago

People

(Reporter: igoldan, Assigned: mattw)

Tracking

(Blocks: 1 bug, {perf, regression, talos-regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=18c74031bd89d38e7663dc7979d6fc8010b69867

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  6%  sessionrestore osx-10-10 opt e10s     938.88 -> 994.75


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=6698

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → WebExtensions: Frontend
Product: Firefox → Toolkit
Version: 54 Branch → unspecified
:mattw Could you please confirm this regresssion? Looks like it's only happening for macosx only.
Flags: needinfo?(mwein)
Flags: needinfo?(jhofmann)

Updated

3 months ago
Assignee: nobody → mwein
Priority: -- → P1
Whiteboard: triaged

Comment 2

3 months ago
pinged matt to comment in bug on status - if wanting to avoid back-out.

Comment 3

3 months ago
Eyeballing this graph, I don't see an obvious visual correlation with this push:
https://treeherder.mozilla.org/perf.html#/graphs?series=%5Bautoland,c22155824871783bb5d8f514b3a01b4c885034c0,1,1%5D&zoom=1495023890817.7778,1495071952897.7778,804.7760465251866,1365.9700763759329

I suspect that whatever is going on here is the same thing that caused bug 1365862 (and that neither the push identified in that bug or the one identified here) is the actual source of the problem.  Can we dup this to 1365862 and continue over there?
Flags: needinfo?(ionut.goldan)
I agree this is slightly confusing, it seems we got very noisy and it could have happened in a variety of different revisions.
(Assignee)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(mwein)
Resolution: --- → DUPLICATE
Duplicate of bug: 1364477
Flags: needinfo?(jhofmann)
Flags: needinfo?(ionut.goldan)
You need to log in before you can comment on or make changes to this bug.