crash in [@StyleSetImpl::ContentInserted] trying to open Preferences

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Bill McGonigle (not currently reading bugmail; please contact directly), Assigned: dbaron)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This happened only once, on 2002032903:

-----
Date/Time:  2002-04-10 10:55:40 -0400
OS Version: 10.1.3 (Build 5Q110)

Command:    Mozilla
PID:        487

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0:
 #0   0x0290b174 in 0x290b174
 #1   0x0290b15c in 0x290b15c
 #2   0x01f440f4 in StyleSetImpl::ContentInserted(nsIPresContext *, nsIContent *)
 #3   0x0282d828 in ContentInserted__9PresShellFP11nsIDocumentP10nsIContentP10nsIC
 #4   0x021ba134 in nsXULDocument::ContentInserted(nsIContent *, nsIContent *, int)
 #5   0x021f7e20 in nsXULElement::InsertChildAt(nsIContent *, int, int, int)
 #6   0x021e5154 in InsertContainerNode__18XULSortServiceImplFP25nsIRDFCompositeDa
 #7   0x02213888 in nsXULContentBuilder::BuildContentFromTemplate(nsIContent *,  *)
 #8   0x02217f34 in ReplaceMatch__19nsXULContentBuilderFP14nsIRDFResourcePC15nsTem
 #9   0x021e9714 in FireNewlyMatchedRules__20nsXULTemplateBuilderFRC15nsClusterKey
 #10  0x021e984c in OnAssert__20nsXULTemplateBuilderFP16nsIRDFDataSourceP14nsIRDFR
 #11  0x01e243f4 in OnAssert__23CompositeDataSourceImplFP16nsIRDFDataSourceP14nsIR
 #12  0x01e14240 in Assert__18InMemoryDataSourceFP14nsIRDFResourceP14nsIRDFResourc
 #13  0x01e265bc in Assert__20RDFXMLDataSourceImplFP14nsIRDFResourceP14nsIRDFResou
 #14  0x01e1cac8 in RDFContentSinkImpl::FlushText(int, int *)
 #15  0x01e1bac0 in RDFContentSinkImpl::HandleEndElement(wchar_t const *)
 #16  0x01e8bfec in nsExpatDriver::HandleEndElement(wchar_t const *)
 #17  0x01e8a9a8 in Driver_HandleEndElement(void *, char const *)
 #18  0x01e92f60 in 0x1e92f60
 #19  0x01e92264 in contentProcessor
 #20  0x01e94c90 in 0x1e94c90
 #21  0x01e94884 in prologProcessor
 #22  0x01e947ec in prologInitProcessor
 #23  0x01e91c74 in XML_Parse
 #24  0x01e8d69c in nsExpatDriver::ParseBuffer(char const *, unsigned int, int)
 #25  0x01e8da58 in nsExpatDriver::ConsumeToken(nsScanner &, int &)
 #26  0x01e76db8 in nsParser::Tokenize(int)
 #27  0x01e73d68 in nsParser::ResumeParse(int, int, int)
 #28  0x01e768a4 in OnDataAvailable__8nsParserFP10nsIRequestP11nsISupportsP14nsIIn
 #29  0x01e2837c in OnDataAvailable__20RDFXMLDataSourceImplFP10nsIRequestP11nsISup
 #30  0x01bcf0cc in OnDataAvailable__13nsFileChannelFP10nsIRequestP11nsISupportsP1
 #31  0x01bde770 in nsOnDataAvailableEvent::HandleEvent(void)
 #32  0x01bec400 in nsARequestObserverEvent::HandlePLEvent(PLEvent *)
 #33  0x005f32e0 in PL_HandleEvent
 #34  0x005f314c in PL_ProcessPendingEvents
 #35  0x00598c4c in nsEventQueueImpl::ProcessPendingEvents(void)
 #36  0x0247b98c in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #37  0x0247b830 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #38  0x00731b14 in Repeater::DoRepeaters(EventRecord const &)
 #39  0x0248fc28 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #40  0x0248f950 in nsMacMessagePump::DoMessagePump(void)
 #41  0x0248f2cc in nsAppShell::Run(void)
 #42  0x0244232c in nsAppShellService::Run(void)
 #43  0x004c9224 in main1(int, char **, nsISupports *)
 #44  0x004c9c6c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x70283ea4 in TSWaitOnConditionTimedRelative
 #4   0x7027d748 in TSWaitOnSemaphoreCommon
 #5   0x702c2078 in TimerThread
 #6   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body


PPC Thread State:
  srr0: 0x0290b174 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x0000000e   lr: 0x0290b15c  ctr: 0x00632b50   mq: 0x00000000
    r0: 0x0290b15c   r1: 0xbfffd7a0   r2: 0x02a4a000   r3: 0x00000000
    r4: 0xbfffd6c8   r5: 0x00000000   r6: 0x04724c20   r7: 0x04724ca0
    r8: 0x00000000   r9: 0x00000001  r10: 0x029f96e4  r11: 0xcaabf76f
   r12: 0x00100218  r13: 0x00000000  r14: 0x00000036  r15: 0x000625f0
   r16: 0x00000001  r17: 0x80160fa8  r18: 0x000586a8  r19: 0x00001907
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x7016b0dc  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0xc0cc2000
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x87859393  r31: 0x00000001

**********

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
-> style
Assignee: jaggernaut → dbaron
Component: XP Toolkit/Widgets → Style System
QA Contact: jrgm → ian

Updated

16 years ago
Summary: crash in StyleSetImpl::ContentInserted trying to open Preferences → crash in [@StyleSetImpl::ContentInserted] trying to open Preferences

Comment 2

16 years ago
WorksForMe using FizzillaCFM/2002041712 (RC1).
Yeah, I wouldn't expect it to be arbitrarily reproducible.  (This happened only
once)  I'm not sure what the proper conditions are.
(Assignee)

Comment 4

16 years ago
Could be a duplicate of bug 133219 (although the stack is really too different)
or something else, but marking worksforme since I haven't seen any other reports
of this crash and we don't have any idea how to reproduce.  If you see this
again and/or have any better ideas about how to reproduce the bug, then please
reopen this bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@StyleSetImpl::ContentInserted]
You need to log in before you can comment on or make changes to this bug.