Remove animation from new robot icon as introduced in bug

RESOLVED FIXED in Firefox 55

Status

P2
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: whimboo, Assigned: ato)

Tracking

({regression})

unspecified
mozilla55
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Since the patch on bug 1355890 landed we see a lot of test failures for the full screenshot test on bug 1364762. As investigation on bug 1364762 has shown this happens because the robot is animated (rolling eyes).

I wonder if we should better remove this animation.
Flags: needinfo?(ato)
(Assignee)

Comment 1

a year ago
I think removing the animation is prudent.
Flags: needinfo?(ato)
(Assignee)

Updated

a year ago
Priority: -- → P2
(Reporter)

Comment 2

a year ago
Andreas, this is the reason for bug 1364762 which has a massive increase of failures. For last week it's the #3 top OF failure. So we need to remove the animation or skip the test ASAP. Thanks.
Assignee: nobody → ato
Flags: needinfo?(ato)
(Reporter)

Comment 3

a year ago
Created attachment 8869966 [details]
Screenshot (overdrawn locationbar border)

Also it looks like that we overdraw the location bar border.
(Assignee)

Comment 4

a year ago
Not sure what the needinfo is for.
Flags: needinfo?(ato)
Comment hidden (mozreview-request)

Comment 6

a year ago
mozreview-review
Comment on attachment 8870394 [details]
Bug 1366366 - Use non-animated robot icon with Marionette;

https://reviewboard.mozilla.org/r/141844/#review145490

rs=me, but can we either name this 'static-robot' or something, or rename the other icon, to avoid this happening to other people who accidentally use the 'wrong' icon? :-)
Attachment #8870394 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Updated

a year ago
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 8

a year ago
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d90b1a36e1a
Use non-animated robot icon with Marionette; r=Gijs

Comment 9

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5d90b1a36e1a
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.