Closed Bug 1366424 Opened 2 years ago Closed 2 years ago

Drop down marker of folder on Bookmark Toolbar is unnecessary

Categories

(Firefox :: Theme, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Iteration:
55.6 - May 29
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 + fixed

People

(Reporter: alice0775, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: regression, ux-minimalism, Whiteboard: [photon-visual][p1])

Attachments

(2 files)

[Tracking Requested - why for this release]: Surplus space is needed fir the drop down marker. And Violation ux-minimalism

Drop down marker of folder on Bookmark Toolbar is unnecessary.

Reason:

1. Surplus space is needed fir the drop down marker.
2. There are already folder icon. There is no way for confusion.
3. Menu item in Menu bar do not have drop down marker.
4. Menu Button do not have drop down marker.
Attached image screenshot
It look messy.
Summary: Drop down marker of folder on Bookmark Toolbar is unnecessary. → Drop down marker of folder on Bookmark Toolbar is unnecessary. It looks messy.
Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df404e72597d2754290a95a18782ec31bc0027b3&tochange=a4235c4be96edaf90b5d6d7c20272a8761ca2339

Regressed by:
	01ae37c9efc0	Johann Hofmann — Bug 1361686 - Share bookmark toolbar button styling between platforms. r=dao
Summary: Drop down marker of folder on Bookmark Toolbar is unnecessary. It looks messy. → Drop down marker of folder on Bookmark Toolbar is unnecessary. It looks messy and noisy.
I'm starting to think we should just remove this across platforms...
Blocks: 1365593
Up to shorlander, really. I don't mind either way. I can see that it has its virtues and it has been there on non-Windows platforms for a long time without anyone opening a bug for it afaik. But we can also remove it. It's part of the Photon spec cross-platform, that's why I enabled it on Windows.
Flags: needinfo?(shorlander)
For me it makes my bookmarks toolbar 21 "arrows" wider, which I don't like. 
RSS feeds are treated as folders, do they need to be?
Not tracking for 55, I will let the photon team handle this :)
Flags: needinfo?(shorlander)
Summary: Drop down marker of folder on Bookmark Toolbar is unnecessary. It looks messy and noisy. → Drop down marker of folder on Bookmark Toolbar is unnecessary
Yeah the arrow is redundant since we also have the folder icon(s) to indicate that is has a menu. Let's remove it everywhere and save some space.
OS: Windows 10 → All
Priority: -- → P2
Hardware: Unspecified → All
Whiteboard: [photon-visual][p1]
Whiteboard: [photon-visual][p1] → [photon-visual][p1] [triage]
Already discussed in the meeting that we should do this.

[Tracking Requested - why for this release]: This needs to be fixed in 55 so that we don't regress how many bookmarks can fit in the toolbar on Windows.
Whiteboard: [photon-visual][p1] [triage] → [photon-visual][p1]
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: brindusa.tot
Blocks: 1367172
Assignee: nobody → dao+bmo
Mentor: nhnt11
Status: NEW → ASSIGNED
Mentor: nhnt11
Priority: P2 → P1
Comment on attachment 8871690 [details]
Bug 1366424 - Remove dropdown arrow from bookmarks toolbar folders.

https://reviewboard.mozilla.org/r/143196/#review146922

Thanks!
Attachment #8871690 - Flags: review?(nhnt11) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/958964b3117b
Remove dropdown arrow from bookmarks toolbar folders. r=nhnt11
Apparently shared/jar.mn.inc wasn't part of my patch although I'm pretty sure I modified it...
Flags: needinfo?(dao+bmo)
Iteration: --- → 55.6 - May 29
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36094daddfd1
Remove dropdown arrow from bookmarks toolbar folders. r=nhnt11
https://hg.mozilla.org/mozilla-central/rev/36094daddfd1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
No longer depends on: 1368580
I have reproduce this bug with Nightly 55.0a1 (2017-05-19) (64-bit) in Windows 10.

This bug's fix is verified with latest Nightly 55.0a1 (64-bit).
 
Build ID   :    20170529030204
User Agent :	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0



[bugday-20170524]
I have reproduced this bug with Nightly 55.0a1 (2017-05-19) on Ubuntu 16.04, 64 bit!

The fix is now verified on latest Nightly!

Build ID 	20170531100318
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

As per Comment 18 & Comment 19, I am also marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-20170531]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.