Publish "renames" duplicate image on previously published page.

VERIFIED INVALID

Status

SeaMonkey
Composer
--
minor
VERIFIED INVALID
16 years ago
a year ago

People

(Reporter: TucsonTester1, Assigned: Brade)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020409 Netscape6/6.2.1+
BuildID:    2002040903

Publisher will "rename" a duplicate image by adding (..._002.xxx)if the page has
been previously published with the original image.  

Reproducible: Always
Steps to Reproduce:
1.Install/Launch NS 6.2.1+
2.Launch new/blank Composer window.
3.Add image to page and publish to ftp site (image to main directory).
4.Reopen page in Composer.
5.Add same image elsewhere on page.
6.Publish page to same ftp site.

Actual Results:  Publisher "renames" the second image by adding (..._002.xxx) to
the name of the image filename.  

Expected Results:  Publisher recognizes the image has been previously uploaded
and retains the image filename.

If the same image is repeated throughout the page prior to publishing, Publisher
will only upload the original image.  Consecutive publishing after inserting a
duplicate image will add 003, 004, ..etc.  Although this may be WAD, the image
name is not "renamed" if a duplicate image is published to a different filename
within the same ftp site.  For example, if an image is published to "index.html"
in an ftp site and then the same image is published to "mypage.html" in the same
ftp site; Publisher recognizes the image already exists on the ftp site.

Updated

16 years ago
Summary: Publisher "renames" duplicate image on previously published page. → Publish "renames" duplicate image on previously published page.

Comment 1

16 years ago
Brade owns image name issues during publishing.
Assignee: cmanske → brade
(Assignee)

Comment 2

16 years ago
I suspect this is a WONTFIX or INVALID bug.

Can you clarify step 5?
>5.Add same image elsewhere on page.

How are you adding this image?  If you really want it to be the same image then
you should use the new location where you already uploaded the image.  If you
are using an image from the OS, publishing is working as expected since the
images aren't necessarily the same.
(Reporter)

Comment 3

16 years ago
Yes, to clarify, I was using an image from the OS and see why it was "renaming".
 Composer does seem to be working as expected, this is probably an INVALID bug.  

Comment 4

16 years ago
invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Blocks: 1367490
No longer blocks: 1367490
You need to log in before you can comment on or make changes to this bug.