-Werror=ignored-attributes: ignoring attributes applied to '__va_list_tag' after definition

RESOLVED DUPLICATE of bug 1363116

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1363116
9 months ago
7 months ago

People

(Reporter: sylvestre, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
With gcc 7.1:
---
 0:25.76 In file included from /root/firefox-gcc-last/js/src/frontend/BytecodeEmitter.h:20:0,
 0:25.76                  from /root/firefox-gcc-last/js/src/frontend/BytecodeCompiler.cpp:16,
 0:25.76                  from /root/firefox-gcc-last/obj-x86_64-pc-linux-gnu/js/src/Unified_cpp_js_src3.cpp:29:
 0:25.76 /root/firefox-gcc-last/js/src/frontend/EitherParser.h: In instantiation of 'bool js::frontend::EitherParser<ParseHandler>::reportExtraWarningErrorNumberVA(Args&& ...) [with Args = {std::nullptr_t, unsigned int&, unsigned int&, __va_list_tag (&)[1]}; ParseHandler = js::frontend::FullParseHandler]':
 0:25.76 /root/firefox-gcc-last/js/src/frontend/BytecodeEmitter.cpp:3661:95:   required from here
 0:25.76 /root/firefox-gcc-last/js/src/frontend/EitherParser.h:253:13: error: ignoring attributes applied to '__va_list_tag' after definition [-Werror=attributes]
 0:25.77              matcher { mozilla::Forward<Args>(args)... };
 0:25.77              ^~~~~~~
 0:25.77 /root/firefox-gcc-last/js/src/frontend/EitherParser.h:253:13: error: ignoring attributes on template argument 'mozilla::detail::DecaySelector<__va_list_tag [1], true, false>::Type {aka __va_list_tag*}' [-Werror=ignored-attributes]
 0:25.77 /root/firefox-gcc-last/js/src/frontend/EitherParser.h: In instantiation of 'bool js::frontend::EitherParser<ParseHandler>::reportStrictModeErrorNumberVA(Args&& ...) [with Args = {std::nullptr_t, unsigned int&, bool, unsigned int&, __va_list_tag (&)[1]}; ParseHandler = js::frontend::FullParseHandler]':
 0:25.77 /root/firefox-gcc-last/js/src/frontend/BytecodeEmitter.cpp:3675:73:   required from here
 0:25.77 /root/firefox-gcc-last/js/src/frontend/EitherParser.h:281:13: error: ignoring attributes applied to '__va_list_tag' after definition [-Werror=attributes]
 0:25.78              matcher { mozilla::Forward<Args>(args)... };
 0:25.78              ^~~~~~~
 0:25.78 /root/firefox-gcc-last/js/src/frontend/EitherParser.h:281:13: error: ignoring attributes on template argument 'mozilla::detail::DecaySelector<__va_list_tag [1], true, false>::Type {aka __va_list_tag*}' [-Werror=ignored-attributes]
----
(Reporter)

Comment 1

9 months ago
Arai, does it ring a bell?
Thanks
Flags: needinfo?(arai.unmht)
I'm not sure what's going on , but looks like it's a dupe of bug 1363116
Flags: needinfo?(arai.unmht)
(Reporter)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363116
You need to log in before you can comment on or make changes to this bug.