There should be a way to use "insertCSS" or to inject JS on pages with CSP

RESOLVED DUPLICATE of bug 1267027

Status

defect
RESOLVED DUPLICATE of bug 1267027
2 years ago
10 months ago

People

(Reporter: Manuel.Spam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Currently on pages with CSP headers it is impossible to do some (maybe even all) modifications on websites.

This actually allows websites to block the Addon API completely. Maybe this even limits what Adblockers or Addons like "Stylish" can do to "fix" broken websites.

If more and more websites implement this feature (which would be a good idea for nearly every website), then the Addon API would get more and more useless.

There should be a way to give Addons, which are verified and signed by Mozilla, access to CSP protected sites! So please provide some way for Addons to have full access to all websites. Maybe create a new permission for this. "This Addon can modify protected websites" or something like that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1267027

Updated

10 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.