Debugger view resets to left when hits stop point

RESOLVED INVALID

Status

RESOLVED INVALID
a year ago
3 months ago

People

(Reporter: 61.1p57, Unassigned)

Tracking

({testcase})

54 Branch
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

92.71 KB, image/png
Details
549 bytes, application/x-zip-compressed
Details
326 bytes, application/x-javascript
Details
384 bytes, text/html
Details
(Reporter)

Description

a year ago
Created attachment 8869906 [details]
screenshot.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170518105722

Steps to reproduce:

1. Try to debug a large script such as [1]
2. Prettify the file and set a stop point.
3. Wait to hit the stop point.

[1]: https://static.zhihu.com/heifetz/main.app.bee929b7e0ed5d163c2d.js


Actual results:

The debugger view resets to left, which shows nothing except spaces.
After dragging the slide to see the code, every step also resets the review to left.


Expected results:

The view should show the code properly.
Component: Untriaged → Developer Tools: Debugger

Comment 1

a year ago
I get 403 Forbidden for the JS script, could you attach it to the bug report, please.
Flags: needinfo?(61.1p57)
(Reporter)

Comment 2

a year ago
Created attachment 8870228 [details]
Reduction for Bug 1366653

Doesn't have to be that js file. Uploading a reduction.
Flags: needinfo?(61.1p57)

Comment 3

a year ago
Created attachment 8870233 [details]
index.js

Comment 4

a year ago
Created attachment 8870234 [details]
index.html

Updated

a year ago
Keywords: testcase
I believe this has since been fixed.
(Reporter)

Comment 6

a year ago
I can confirm that the prettify code button (which is required for reproduce this bug) is hidden after [0], and the bug is fixed after [1] when the prettify code button comes back. It is not even merged into beta, so I have to use nightly for verifying.

[0] https://hg.mozilla.org/mozilla-central/rev/a71db5e5d89b
[1] https://hg.mozilla.org/mozilla-central/rev/a10837dc8cdf
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.