Error Console uses the wrong highlight color for selections

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
--
trivial
RESOLVED WONTFIX
15 years ago
11 months ago

People

(Reporter: Matthew Paul Thomas, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
Build: 2002040508, Mac OS 9.1

To reproduce:
1.  Open the JavaScript Console.
2.  Click on one of the errors to select it.

What happens:
*   It goes blue.

What should happen:
*   It goes pink, since that's my chosen highlight color.
(Reporter)

Updated

15 years ago
Severity: normal → trivial

Comment 1

14 years ago
Console still uses its own custom color rather than system color.
OS: Mac System 9.x → MacOS X

Updated

11 years ago
Summary: JavaScript Console uses the wrong highlight color for selections → Error Console uses the wrong highlight color for selections
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
QA Contact: jrgmorrison → error-console

Comment 2

9 years ago
Bumping this to toolkit, since the css is there. One problem here is of course that with a system color like "Highlight", you might end up with the same color as the various background colors that are used to differentiate messages/warnings etc.
Component: Error Console → Error Console
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console

Comment 3

9 years ago
> One problem here is of course
> that with a system color like "Highlight", you might end up with the same color
> as the various background colors that are used to differentiate
> messages/warnings etc.

Yes see Bug 414244 for an example.
OS: Mac OS X → All
Hardware: PowerPC → All
Depends on: 490886

Updated

8 years ago
Blocks: 490886
No longer depends on: 490886
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX

Comment 5

11 months ago
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
Doesn't translate to browser console, so resolving
Status: REOPENED → RESOLVED
Last Resolved: 11 months ago11 months ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

11 months ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.