add version information to mozilla.exe

VERIFIED FIXED in mozilla1.2alpha

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Jon Granrose, Assigned: Aki Sasaki)

Tracking

Trunk
mozilla1.2alpha
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: has patch, needs review)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
This is an offshoot of 23560.  mozilla.exe needs version information in the file
properties.
(Reporter)

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.1alpha
(Assignee)

Comment 1

16 years ago
Created attachment 79315 [details] [diff] [review]
adds RCINCLUDE functionality and modifies xpfe/bootstrap makefiles to take advantage and autoversion mozilla.exe
(Assignee)

Comment 2

16 years ago
This patch also fixes the nmake versioning... -TOPSRCDIR $(topsrcdir) changed to
-TOPSRCDIR $(DEPTH) in version.inc since topsrcdir isn't set in nmake builds.

This is breaking autoversioning in all nmake mozilla builds since -OFFICIAL 1 is
after the -TOPSRCDIR bit, and the missing argument horked the rest of the
command line... everything's permanently set to 0.0.0.0 without this patch
(which I knew of for a while, but thought would only be a temporary cosmetic
problem).

Looking for r=/sr=
Status: NEW → ASSIGNED
Comment on attachment 79315 [details] [diff] [review]
adds RCINCLUDE functionality and modifies xpfe/bootstrap makefiles to take advantage and autoversion mozilla.exe

r=cls
Attachment #79315 - Flags: review+

Comment 4

16 years ago
Comment on attachment 79315 [details] [diff] [review]
adds RCINCLUDE functionality and modifies xpfe/bootstrap makefiles to take advantage and autoversion mozilla.exe

with the caveat that the origin call change be removed, sr=leaf
(marking a=, as well, for build/config blanket)
Attachment #79315 - Flags: superreview+
Attachment #79315 - Flags: approval+
(Assignee)

Comment 5

16 years ago
Created attachment 79374 [details] [diff] [review]
updated version.inc

removes the origin bit, fixes the fix to the topsrcdir bit since my evening
build had a problem with the backslash.
(Assignee)

Comment 6

16 years ago
leaf checked this into the branch...
Keywords: fixed1.0.0
(Assignee)

Comment 7

16 years ago
this appears to be working on the trunk as well. closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
I don't see the version info tab on the mozilla.exe from today's build.  Re-
opening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

16 years ago
It looks like this was never checked in to the trunk.
(Assignee)

Comment 10

16 years ago
Created attachment 89097 [details] [diff] [review]
trunk patch, with module.ver and updated milestone.txt

Trunk patch...

Comment 11

16 years ago
*** Bug 162606 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Whiteboard: has patch, needs review
Target Milestone: mozilla1.1alpha → mozilla1.2alpha
(Assignee)

Comment 12

16 years ago
Created attachment 95915 [details] [diff] [review]
new trunk patch...

the new patch is diffed against today's source, and removes the nmake
functionality since that's not around anymore...
Attachment #89097 - Attachment is obsolete: true
(Assignee)

Comment 13

16 years ago
cls, leaf, could i get an r=/sr= for the trunk?

this patch also fixes bug 138764.
Comment on attachment 95915 [details] [diff] [review]
new trunk patch...

r=cls
Attachment #95915 - Flags: review+
(Assignee)

Comment 15

16 years ago
checked into the trunk.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
Verified fixed using 2002082508.  Properties for mozilla.exe has a Version tab.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.