Bug 1366831 (Build_Datasets)

[meta] Build Quantum Release Criteria Datasets

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: frank, Unassigned)

Tracking

(Blocks: 1 bug, {meta})

Details

(Reporter)

Description

a year ago
This is a meta-bug for the Quantum Release Criteria datasets. See discussion in [0] and [1] for a rough overview of what was asked for.

[0] https://groups.google.com/a/mozilla.com/forum/#!topic/mission-control-leads/uyAKdCZh3yQ
[1] https://groups.google.com/a/mozilla.com/forum/#!topic/mission-control-leads/LTPlbDB5kDA
(Reporter)

Updated

a year ago
Depends on: 1366834
(Reporter)

Updated

a year ago
Depends on: 1366836
(Reporter)

Updated

a year ago
Depends on: 1366835
(Reporter)

Updated

a year ago
Depends on: 1366838
(Reporter)

Comment 1

a year ago
Quantum-ready is defined in the following way:

- e10s is enabled defined as environment.settings.e10sEnabled == true

-all enabled addons are either system addons or webextensions defined by checking environment.addons.activeAddons for .isSystem || .isWebExtension

- They aren't using an old-style (heavyweight) theme, i.e. environment.addons.theme.id in ('{972ce4c6-7e08-4474-a285-3208198ce6fd}', 'firefox-compact-light@mozilla.org', 'firefox-compact-dark@mozilla.org')
Blocks: 1325169
Keywords: meta

Updated

a year ago
Alias: Build_Datasets

Updated

a year ago
Blocks: 1370336

Updated

a year ago
No longer blocks: 1325169
(Reporter)

Updated

a year ago
Duplicate of this bug: 1371813
(Reporter)

Updated

a year ago
Points: --- → 3
Priority: -- → P1
(Reporter)

Updated

a year ago
Depends on: 1375108
(Reporter)

Comment 3

a year ago
The data is available in s3://telemetry-parquet/quantum_rc.

The table is available in re:dash as `quantum_rc`. Here is an example query: https://sql.telemetry.mozilla.org/queries/4929/source#table
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.