Closed Bug 1366855 Opened 7 years ago Closed 7 years ago

Opening links from other programs in Firefox/Thunderbird is broken, shows "X is already running, but not responding" message

Categories

(Firefox :: Untriaged, defect, P3)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 382477

People

(Reporter: pollti, Unassigned)

Details

STR:
# Set Thunderbird as your default e-mail application.
# Open Thunderbird.
# Open any page in Firefox 55+.
# In adressbar, click ...
# Choose "Email Link…".

Actual result:
Thunderbird doesn't open a new compose window. I get the following window:
"Thunderbird is already running, but is not responding. The old Thunderbird process must be closed to open a new window."

Can anyone confirm this behavior?
Whiteboard: [photon-structure]
Whiteboard: [photon-structure] → [photon-structure] [triage]
Blocks: 1355323
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-structure] [triage] → [reserve-photon-structure] [triage]
(In reply to Tim [:pollti] from comment #0)
> STR:
> # Set Thunderbird as your default e-mail application.
> # Open Thunderbird.
> # Open any page in Firefox 55+.
> # In adressbar, click ...
> # Choose "Email Link…".
> 
> Actual result:
> Thunderbird doesn't open a new compose window. I get the following window:
> "Thunderbird is already running, but is not responding. The old Thunderbird
> process must be closed to open a new window."
> 
> Can anyone confirm this behavior?

I can't reproduce. What OS is this on, and what version of Thunderbird? (I tested on OS X)

In principle, I think this is likely a Thunderbird issue. The email link item has always existed (as a toolbar button and in the traditional File menu) and I would expect those to have the same issue.
Flags: needinfo?(pollti)
Whiteboard: [reserve-photon-structure] [triage] → [reserve-photon-structure]
It was Windows 10 Firefox 55 64 bit and Thunderbird 45.8 32 bit. It is also happening in Fx 53.0.3 with TB 52.1.1.
I get the same error when trying to open Links from other programs in Firefox now, so it seems to be problematic and not only a TB or FX problem (not sure which product is best for this bug).
Flags: needinfo?(pollti)
OS: Windows 10 → All
Hardware: x86_64 → Unspecified
OS: All → Windows 10
(In reply to Tim [:pollti] from comment #2)
> It was Windows 10 Firefox 55 64 bit and Thunderbird 45.8 32 bit. It is also
> happening in Fx 53.0.3 with TB 52.1.1.
> I get the same error when trying to open Links from other programs in
> Firefox now, so it seems to be problematic and not only a TB or FX problem
> (not sure which product is best for this bug).

I'm not sure either. Does restarting either/both programs help? Do you have multiple Firefox/Thunderbird profiles set up? Does it happen with a new, clean profile (on the 'receiving' end of the link being sent somewhere) ? ( https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles )
No longer blocks: 1355323
Component: Location Bar → Untriaged
Flags: qe-verify? → needinfo?(pollti)
Summary: sending link from adresbar with thunderbird as default e-mail program doesn't work correctly → Opening links from other programs in Firefox/Thunderbird is broken, shows "X is already running, but not responding" message
Whiteboard: [reserve-photon-structure]
You are right! It was caused by Firefox being executed with "-no-remote" paramater. Is the behavior intended then?
Flags: needinfo?(pollti)
(In reply to Tim [:pollti] from comment #4)
> You are right! It was caused by Firefox being executed with "-no-remote"
> paramater. Is the behavior intended then?

I don't think so. It looks like it's a dupe of bug 382477, though note also bug 424649.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.