Integrate tabs in GNOME's titlebar

RESOLVED DUPLICATE of bug 513159

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 513159
7 months ago
7 months ago

People

(Reporter: rugk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
Currently in GNOME Firefox has a big title bar and a tab bar below. This wastes much vertical space and also looks ugly. That's why it would be nice, if Firefox could integrate it's tabs there in the same way as with Windows (7 Aero e.g.), where you only have one bar.

And this is possible as there is already an (old legacy) add-on on AMO: https://addons.mozilla.org/de/firefox/addon/htitle/
(including screenshots)
Code here: https://github.com/seleznev/firefox-extension-htitle

However, this extension is discontinued and with the requirement of WebExtensions in Firefox 47 the add-on cannot be used for this functionality anymore. Additionally, it is of course much nicer, if this – really basic – feature is already integrated into Firefox.

Updated

7 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 513159
You need to log in before you can comment on or make changes to this bug.