Not consistent back button is too white and stands out too much after landing patch from bug #1365195

VERIFIED FIXED in Firefox 55

Status

()

VERIFIED FIXED
a year ago
6 months ago

People

(Reporter: Virtual, Assigned: dao)

Tracking

({nightly-community, regression, ux-consistency})

55 Branch
Firefox 55
x86_64
Windows 7
nightly-community, regression, ux-consistency
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 verified)

Details

(Whiteboard: [fixed by patch from bug #1367712])

Attachments

(2 attachments)

STR:
1. Open Mozilla Firefox Nightly 55.0a1 (2017-05-23)
2. Open some website pages to see working back button
3. See that back button is too white and stands out too much compared to other buttons in Mozilla Firefox Nightly 55.0a1 (2017-05-22)



"Speedy" Regression window (mozilla-central)
Good:
https://ftp.mozilla.org/pub/firefox/nightly/2017/05/2017-05-22-03-02-07-mozilla-central/

Bad:
https://ftp.mozilla.org/pub/firefox/nightly/2017/05/2017-05-23-03-02-06-mozilla-central/

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9851fcb0bf4d855c36729d7de19f0fa5c9f69776&tochange=5bc1c758ab57c1885dceab4e7837e58af27b998c

Probably caused by:
07facc83000c	Nihanth Subramanya — Bug 1365195 - [Photon] Implement new back button appearance. r=dao
Flags: needinfo?(nhnt11)
Created attachment 8870416 [details]
back button in Mozilla Firefox  Nightly 55.0a1 (2017-05-23).png
(Assignee)

Updated

a year ago
Severity: major → normal
status-firefox55: affected → ---
Keywords: regressionwindow-wanted
Whiteboard: [photon-visual][triage]
Attachment #8870416 - Attachment description: back button.png → back button in Mozilla Firefox Nightly 55.0a1 (2017-05-23).png
Attachment #8870416 - Attachment filename: back button.png → back button in Mozilla Firefox Nightly 55.0a1 (2017-05-23).png
Created attachment 8870423 [details]
back button in Mozilla Firefox  Nightly 55.0a1 (2017-05-22).png
Has Regression Range: --- → yes
Has STR: --- → yes
Summary: Back button is too white and stands out too much in Mozilla Firefox Nightly 55.0a1 (2017-05-23) → Not consistent back button is too white and stands out too much after landing patch from bug #1365195
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
(Assignee)

Updated

a year ago
Depends on: 1367712
(Assignee)

Comment 3

a year ago
I think bug 1367712 made the back button stand out a bit less, to the point where I think this is now looking as specified.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(nhnt11)
Resolution: --- → WORKSFORME
Flags: qe-verify?
Priority: P3 → --
Whiteboard: [reserve-photon-visual]
Unfortunately, it's not fixed in all cases, especially when user is using Persona/LightTheme/Appearance.

@ Dão Gottwald [::dao] - How about using the same button style on back button like on other buttons, but only when user is using Persona/LightTheme/Appearance, so it will be consistent, not too white and not standing out too much, especially with darker themes.
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 5

a year ago
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #4)
> Unfortunately, it's not fixed in all cases, especially when user is using
> Persona/LightTheme/Appearance.

This appears to be intentional, see the "Spring Rain" option here: https://people-mozilla.org/~shorlander/projects/photon/Mockups/windows-10.html
Flags: needinfo?(dao+bmo)
OK. Thank you very much for detailed explanation.
Status: RESOLVED → VERIFIED
status-firefox55: --- → verified
Resolution: WORKSFORME → FIXED
Whiteboard: [fixed by patch from bug #1367712]
You need to log in before you can comment on or make changes to this bug.