Closed Bug 1367072 Opened 4 years ago Closed 3 years ago

/service-workers/service-worker/fetch-request-html-imports.https.html test crashes in debug

Categories

(Core :: DOM: Service Workers, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jgraham, Unassigned)

References

Details

This also seems to cause a restart loop in wptrunner so disabling for now. I don't seem to have a good stack in the logs. Locally I see a content crash (but no restart loop).
Keywords: leave-open
Priority: -- → P3
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4c30acad2fd7
Disable crashing test in wpt import, a=testonly
The leave-open keyword is there and there is no activity for 6 months.
:overholt, maybe it's time to close this bug?
Flags: needinfo?(overholt)
Perry, can you see if this test is still crashing in debug builds?
Flags: needinfo?(overholt) → needinfo?(perry)
The test isn't crashing in debug builds for me (with the latest mozilla-central). FWIW I don't recall ever seeing this test crash either.
Flags: needinfo?(perry)
Did you reenable the test? It was an intermittent crash so it would be useful to see a try run with the patch to disable it backed out out and something like

./mach try fuzzy -q debug --artifact --rebuild 20 testing/web-platform/service-workers/service-worker/

to check if there is still a high-frequency intermittent here.
(In reply to James Graham [:jgraham] from comment #6)
> Did you reenable the test? It was an intermittent crash so it would be
> useful to see a try run with the patch to disable it backed out out and
> something like
> 
> ./mach try fuzzy -q debug --artifact --rebuild 20
> testing/web-platform/service-workers/service-worker/
> 
> to check if there is still a high-frequency intermittent here.

It looks like the changes to disable the test have already been removed (https://searchfox.org/mozilla-central/source/testing/web-platform/meta/service-workers/service-worker/fetch-request-html-imports.https.html.ini). I did do a try run on debug builds with 20 retriggers, and it's all green: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d8ef4370cf6860f79e7697404d9e6f7b8abc42ce
Given the stuff in comment 7, could we close this Andrew?
Flags: needinfo?(overholt)
SGTM!
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(overholt)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.