WebExtensions API to change appearance of tabs

RESOLVED DUPLICATE of bug 1320585

Status

RESOLVED DUPLICATE of bug 1320585
2 years ago
5 months ago

People

(Reporter: flying-sheep, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170521144518

Steps to reproduce:

My addon adds a stylesheet to display unloaded tabs as semitransparent.

In order to convert it into a WebExtension, I need a way to change the opacity, font color, or another prominent visual feature of unloaded tabs to make it look faded.

Updated

2 years ago
Flags: needinfo?(amckay)

Comment 1

2 years ago
The new themeing API allows some of these, see bug 1330328 for more. Applying a general stylesheet for tabs isn't a goal for WebExtensions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Duplicate of bug: 1330328
(Reporter)

Comment 2

2 years ago
that bug has no information though.

where are docs about that theming API?

can i modify the look of individual tabs programmatically from my addon? if the answer is “no”, this is not a duplicate.

Comment 3

2 years ago
This feature request is essentially the same as bug 1320585.

To not fragment the discussion, please continue the above conversation at bug 1320585.
Duplicate of bug: 1320585

Updated

5 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.