If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

infojobs.net - login form doesn't work if the email has a period in the username

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Spanish
P3
major
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Unai, Unassigned)

Tracking

Details

(Whiteboard: [SYNTAX-JS], URL)

(Reporter)

Description

16 years ago
In the top part of the web there's a login form, where the e-mail and password
must be entered. If the e-mail has a colon in the username, a pop-up appears
saying that it's incorrect. (tried with my email unai.astorkiza@wanadoo.es).

I've tried the same page with konkeror, opera and IE. I can login with Konqueror
and IE, but Mozilla and Opera show me the error popup.

      Unai

Comment 1

16 years ago
I got an error message using both a colon and a period (wasn't sure which to try
since period listed in email given and in summary, but colon named).  I know
periods are okay.

Confirmed
2002040903/WinXP

Suspect JS:
function validar(){if ((mail_infojobs(document.myForm.email)==false) ||
(mail(document.myForm.email)==false) ||
(longitud(document.myForm.password,"password",4,20)==false))
return(false);document.myForm.submit();return(true);}self.status="Login de
Candidato";
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: The login form doesn't work if the e-mail has a "." in the username → infojobs.net - login form doesn't work if the email has a period in the username
Whiteboard: [eurocontest][SYNTAX-JS]

Comment 2

15 years ago
email string checking is in http://www.infojobs.net/func_mail_01.js
OS: Linux → All
Hardware: PC → All
New Component
Component: Europe: West → Spanish

Comment 4

14 years ago
spanish default owner
Assignee: nitot → spanish
QA Contact: z-caillon-obsolete2 → spanish

Comment 5

14 years ago
it seems to work fine for me now.
Unai, could you please try to see if the login really works?
WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Whiteboard: [eurocontest][SYNTAX-JS] → [SYNTAX-JS]
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.