Closed Bug 1367226 Opened 3 years ago Closed 3 years ago

Remove unused pref: plugins.navigator_hide_disabled_flash

Categories

(Core :: Plug-ins, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox54 --- wontfix
firefox55 --- fixed
firefox56 --- fixed

People

(Reporter: darkspirit, Assigned: cpeterson)

Details

(Keywords: good-first-bug)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170523100217

Steps to reproduce:

I opened about:config and wanted to see if I can deactivate NPAPI plugins and googled those prefs and also looked on https://dxr.mozilla.org. Then I found this:
https://dxr.mozilla.org/mozilla-central/search?q=plugins.navigator_hide_disabled_flash&redirect=false
Am I correct that this pref is no longer in use and should be removed from Firefox or does the Adobe Flash Plugin check that pref?
Component: Untriaged → Plug-ins
Product: Firefox → Core
Version: 55 Branch → Trunk
Yes that is correct.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Assignee: nobody → cpeterson
Comment on attachment 8886486 [details]
Bug 1367226 - Remove unused pref "plugins.navigator_hide_disabled_flash".

https://reviewboard.mozilla.org/r/157284/#review162904
Attachment #8886486 - Flags: review?(benjamin) → review+
Pushed by cpeterson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b9f81280f19
Remove unused pref "plugins.navigator_hide_disabled_flash". r=bsmedberg
https://hg.mozilla.org/mozilla-central/rev/0b9f81280f19
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Comment on attachment 8886486 [details]
Bug 1367226 - Remove unused pref "plugins.navigator_hide_disabled_flash".

Approval Request Comment
[Feature/Bug causing the regression]: No regression
[User impact if declined]: We removed the "plugin hiding" feature in Firefox 55. To avoid user confusion, we should also remove the pref to enable the feature.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Not risky because it is only removing an unused pref.
[String changes made/needed]: No string changes
Attachment #8886486 - Flags: approval-mozilla-beta?
Comment on attachment 8886486 [details]
Bug 1367226 - Remove unused pref "plugins.navigator_hide_disabled_flash".

remove dead pref, beta55+
Attachment #8886486 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Chris Peterson [:cpeterson] from comment #6)
> [Is this code covered by automated tests?]: No
> [Has the fix been verified in Nightly?]: No
> [Needs manual test from QE? If yes, steps to reproduce]: No

Setting qe-verify- based on Chris's assessment on manual testing needs.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.