Endless loop logging into AOL

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: greg, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I click "submit" to try to log onto AOL ( http://www.aol.com/ ), 
the browser goes into an endless reload, alternating between the
pages:

http://my.screenname.aol.com/_cqr/login/login.psp?siteId=aolcomprod&authLev=1&mcState=initialized

and

http://my.screenname.aol.com/_cqr/login/login.psp?siteId=aolcomprod

This loop continues forever, and you never reach a logged in state.

I am using Mozilla 0.9.9 milestone.
Do you see this with Mozilla 1.0RC1 ?
Have you disabled cookies ?
(Reporter)

Comment 2

16 years ago
The behavior is slightly different 1.0rc1.  Instead of an endless loop,
I get bumped back to a different login page:

http://my.screenname.aol.com/_cqr/login/login.psp?siteId=aolcomprod&authLev=1&mcState=initialized&triedAimAuth=y

And if I try to log in at this screen, I get the same screen again.
This is probably the same behavior a user would see if they mis-typed 
their username or password, but I've re-tried it several times.  

I checked that cookies were on, and they were set to "originating web 
site only", so I set it to "accept all", but it still doesn't work, and 
then I noticed that in Netscape I also have it set to accept only from 
the originating web site, and it works fine, so that is not the problem.
I also tried clearing out my cookies to let www.aol.com recreate them.
Same behavior.

This may be a bug in AOL's site, not in Mozilla, but I would assume that
you guys would want the browser to work well with AOL...

Comment 3

16 years ago
Very similar to bug 132169.

Comment 4

16 years ago
RC1 says in status bar that it is trying to connect to 127.0.0.1 for awhile.
Couldn't that be because of trying to get some auth via AOL Instant Messenger?

Comment 5

16 years ago
I had encountered this bug while trying to convince a friend to switch to
Mozilla.  She can login just fine on my computer using 1.0RC1 on Windows XP, but
is kicked back to the login screen when she attempts it on her own computer with
1.0RC1 on Windows 98.
Can you please try a new profile ?

run "mozilla -profilemanager" and create an ADDITIONAL test profile ?
(Reporter)

Comment 7

16 years ago
I moved my .mozilla directory aside and created a new profile and
I was able to successfully log in with 1.0rc1.
(Reporter)

Comment 8

16 years ago
Correction...

It works as long as I have "Accept all Cookies" set.  If I set it to only
accept cookies from the origination site only, I end up in the endless 
loop.

This is still a problem, as I can use that setting just fine on other 
browsers (like Netscape).  It just doesn't work in Mozilla.

Comment 9

16 years ago
Mozilla Build 2002041711: 09:30 May 5, 2002 Jim Webb jimwebb7@aol.com

I have the same problem running on a PC with Windows XP. 
I go to the aol anywhere site: aol.com.

I enter my logname and password, the system does some processing
and returns me to the login screen. Once in about a dozen trys I 
got logged on. So, this problem may be intermittant.

This does not happen when I use Netscape 4.7. On Netscape I get logged
in, in the normal manner.

Comment 10

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> cookies (after comment #8)
Assignee: Matti → morse
Component: Browser-General → Cookies
QA Contact: imajes-qa → tever
(Assignee)

Comment 12

16 years ago
Is this still a problem with the latest trunk (or branch) builds?  There were 
several significant cookie changes that went into the tree in the past few 
weeks.
(Reporter)

Comment 13

16 years ago
Good news.  It now works correctly for me with 1.0rc3.
thanks !

-> wfm
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 15

16 years ago
verified per reporters comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.