Intermittent mozmake.EXE[5]: *** [force-cargo-library-build] Error 101 after error: couldn't create a temp dir: The system cannot find the path specified. (os error 3)

RESOLVED DUPLICATE of bug 1364651

Status

RESOLVED DUPLICATE of bug 1364651
a year ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=101448765&repo=autoland

06:27:31     INFO -  z:/task_1495605654/build/src/obj-firefox/_virtualenv/Scripts/python.exe -m mozbuild.action.cl z:/task_1495605654/build/src/clang/bin/clang.exe --driver-mode=cl -Xclang -std=gnu99 -Fovpx_convolve.obj -c  -DDEBUG=1 -DHAVE_CONFIG_H=vpx_config.h -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -Iz:/task_1495605654/build/src/media/libvpx -Iz:/task_1495605654/build/src/obj-firefox/media/libvpx  -Iz:/task_1495605654/build/src/obj-firefox/dist/include  -Iz:/task_1495605654/build/src/obj-firefox/dist/include/nspr -Iz:/task_1495605654/build/src/obj-firefox/dist/include/nss        -MD -FI z:/task_1495605654/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT  -Qunused-arguments   -Qunused-arguments -TC -nologo -wd4091 -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -Gw -wd4244 -wd4267 -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -we4553  -Zi -Xclang -load -Xclang z:/task_1495605654/build/src/obj-firefox/build/clang-plugin/clang-plugin.dll -Xclang -add-plugin -Xclang moz-check -O1 -Oi -Oy- -Iz:/task_1495605654/build/src/media/libvpx/config/win/x64/ -Wno-sign-compare -Wno-unused-function -Wno-unreachable-code -Wno-unneeded-internal-declaration -Iz:/task_1495605654/build/src/media/libvpx/libvpx -Iz:/task_1495605654/build/src/media/libvpx/config -Fdgenerated.pdb -FS  z:/task_1495605654/build/src/media/libvpx/libvpx/vpx_dsp/vpx_convolve.c
06:27:31     INFO -  error: couldn't create a temp dir: The system cannot find the path specified. (os error 3)
06:27:31     INFO -  mozmake.EXE[5]: Entering directory 'z:/task_1495605654/build/src/obj-firefox/layout/svg'
06:27:31     INFO -  mkdir -p '.deps/'
06:27:31     INFO -  error: Could not compile `gkrust`.
06:27:31     INFO -  Caused by:
06:27:31     INFO -    process didn't exit successfully: `z:/task_1495605654/build/src/rustc/bin/rustc.exe --crate-name gkrust Z:\task_1495605654\build\src\toolkit\library\rust\lib.rs --crate-type staticlib --emit=dep-info,link -C opt-level=1 -C panic=abort -C codegen-units=4 -C debuginfo=2 -C debug-assertions=on --cfg feature="quantum_render" --cfg feature="gkrust-shared" -C metadata=af9e5c64142c29b9 -C extra-filename=-af9e5c64142c29b9 --out-dir z:/task_1495605654/build/src/obj-firefox/toolkit/library\x86_64-pc-windows-msvc\debug\deps --target x86_64-pc-windows-msvc -L dependency=z:/task_1495605654/build/src/obj-firefox/toolkit/library\x86_64-pc-windows-msvc\debug\deps -L dependency=z:/task_1495605654/build/src/obj-firefox/toolkit/library\debug\deps --extern gkrust_shared=z:/task_1495605654/build/src/obj-firefox/toolkit/library\x86_64-pc-windows-msvc\debug\deps\libgkrust_shared-b9d1dfc48fc89b76.rlib` (exit code: 101)
06:27:31     INFO -  z:/task_1495605654/build/src/config/rules.mk:1021: recipe for target 'force-cargo-library-build' failed
06:27:31     INFO -  mozmake.EXE[5]: *** [force-cargo-library-build] Error 101
06:27:31     INFO -  mozmake.EXE[5]: Leaving directory 'z:/task_1495605654/build/src/obj-firefox/toolkit/library/rust'
06:27:31     INFO -  z:/task_1495605654/build/src/config/recurse.mk:73: recipe for target 'toolkit/library/rust/target' failed
06:27:31     INFO -  mozmake.EXE[4]: *** [toolkit/library/rust/target] Error 2
06:27:31     INFO -  mozmake.EXE[4]: *** Waiting for unfinished jobs....
Component: Build Config → General
Depends on: 1364651
Product: Core → Taskcluster
19 failures in 891 pushes (0.021 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* mozilla-inbound: 5
* mozilla-central: 2
* graphics: 1

Platform breakdown:
* windows2012-64: 11
* windows2012-32: 7
* windows2012-32-qr: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1367404&startday=2017-05-22&endday=2017-05-28&tree=all
Duplicate of this bug: 1369455
14 failures in 820 pushes (0.017 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 9
* mozilla-inbound: 4
* mozilla-central: 1

Platform breakdown:
* windows2012-64: 8
* windows2012-32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1367404&startday=2017-05-29&endday=2017-06-04&tree=all
No instances since bug 1364651 was fixed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364651
1 failures in 1008 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1367404&startday=2017-07-24&endday=2017-07-30&tree=all
You need to log in before you can comment on or make changes to this bug.