Change display name (CFBundleName) of content process on OSX/macOS

VERIFIED FIXED in Firefox 55

Status

()

Core
Widget: Cocoa
P2
normal
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: spohl, Assigned: spohl)

Tracking

unspecified
mozilla55
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox55 verified)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 months ago
We should change the display name of the content process on OSX/macOS to differentiate it from the Firefox application. It currently matches the display name of the Firefox application. More specifically, for Nightly, we should change CFBundleName for the content process from "Nightly" to something like "Nightly Content Process".
(Assignee)

Comment 1

7 months ago
Created attachment 8870898 [details] [diff] [review]
Patch

This will need review by a build peer, but I wanted to get your feedback first. Should we get some input from UX about the specific string for the display name here?
Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
Attachment #8870898 - Flags: review?(mstange)
Comment on attachment 8870898 [details] [diff] [review]
Patch

Review of attachment 8870898 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #8870898 - Flags: review?(mstange) → review+

Updated

7 months ago
Priority: -- → P2
Whiteboard: tpi:+
(Assignee)

Comment 3

7 months ago
Created attachment 8871139 [details] [diff] [review]
Patch

I noticed after posting the previous patch that although CFBundleName is a localized string, it shouldn't actually be displayed to the user[1]. Also, it should be 16 characters or less according to Apple's documentation[2].

This patch changes the bundle name for the content process to have "CP" (for "child process" or "content process") appended to MOZ_APP_DISPLAYNAME, so Firefox becomes FirefoxCP and Nightly becomes NightlyCP.

Ted, could you take a look at this patch from a build perspective? Also, would you happen to know if there is any way to mention in the plist that the plugin-container.app should never be launched by itself since it's part of a 'larger' app? Thanks!

[1] https://developer.apple.com/library/content/documentation/General/Reference/InfoPlistKeyReference/Articles/CoreFoundationKeys.html#//apple_ref/doc/uid/TP40009249-SW2 (look for CFBundleName)
[2] https://developer.apple.com/library/content/documentation/General/Reference/InfoPlistKeyReference/Articles/CoreFoundationKeys.html#//apple_ref/doc/uid/TP40009249-109585
Attachment #8870898 - Attachment is obsolete: true
Attachment #8871139 - Flags: review?(ted)
> Ted, could you take a look at this patch from a build perspective? Also, would you happen to know if there is any way to mention in the plist that the plugin-container.app should never be launched by itself since it's part of a 'larger' app? Thanks!

Sorry, I've never heard of anything like that. A brief glance at the Info.plist inside "Google Chrome Helper.app" doesn't show anything enlightening either.
Attachment #8871139 - Flags: review?(ted) → review+
(Assignee)

Comment 5

6 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e297bb6a3ab7ed01bef7774e52651148833d94d
Bug 1367487: Change bundle name (CFBundleName) of content process on OSX/macOS to differentiate it from the Firefox bundle name. r=mstange,ted
(Assignee)

Updated

6 months ago
Flags: qe-verify+
Flags: needinfo?(ryanvm)
Rares, see the email I've forwarded you regarding this as well.
Flags: needinfo?(ryanvm) → needinfo?(rares.bologa)

Comment 7

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6e297bb6a3ab
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Comment 8

6 months ago
Tested Firefox Nightly 55.0a1 (2017-06-05) on Mac mini running macOS Sierra 10.12.5 (16F73).

I was unable to reproduce this issue. Using voice command on Nightly (Ask Siri to 'Launch Nightly') will Launch Firefox Nightly.

Note: 
- For the Nightly channel this works only when saying 'Launch Nightly'.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
Flags: needinfo?(rares.bologa)
(Assignee)

Comment 9

6 months ago
(In reply to Simon Basca [:SimonB] from comment #8)
> Tested Firefox Nightly 55.0a1 (2017-06-05) on Mac mini running macOS Sierra
> 10.12.5 (16F73).
> 
> I was unable to reproduce this issue. Using voice command on Nightly (Ask
> Siri to 'Launch Nightly') will Launch Firefox Nightly.
> 
> Note: 
> - For the Nightly channel this works only when saying 'Launch Nightly'.

Could you confirm that you were able to reproduce the problem before this patch landed? Using what build? Thank you!
Flags: needinfo?(simion.basca)
Re-tested on several builds before the patch has landed 55.0a1 (2017-06-04), (2017-06-01), (2017-05-24), but did not managed to reproduce the issue.
Flags: needinfo?(simion.basca)
(Assignee)

Comment 11

6 months ago
(In reply to Simon Basca [:SimonB] from comment #10)
> Re-tested on several builds before the patch has landed 55.0a1 (2017-06-04),
> (2017-06-01), (2017-05-24), but did not managed to reproduce the issue.

Could you check Firefox release? If this only reproduces with release, we may have to build a one-off build with release-naming to confirm the fix.
Flags: needinfo?(simion.basca)
Also tested on the released version 53.0.3 and was unable to reproduce this issue.
Flags: needinfo?(simion.basca)
You need to log in before you can comment on or make changes to this bug.