The Reply-To header is being ignored

RESOLVED DUPLICATE of bug 1309486

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1309486
6 months ago
5 months ago

People

(Reporter: Shawn Heisey, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170418004027

Steps to reproduce:

Messages sent by mailing lists managed by the Apache Software Foundation include a Reply-To header that references the list email address.

I have been pressing Ctrl-R for years to replyt to messages from these lists, and this has always put the list address in the "to" box of the new message.  Since upgrading to 52.1.1, Ctrl-R is putting the sender's address in the "to" box of my message.  Before I discovered what was happening, I accidentally sent a number of unicast replies instead of messages to the list because of this.

I do have the option of clicking the "Reply List" button, but I have not had to do this in the past -- I have always been able to just press Ctrl-R and begin composing my message.  I do not like to use the mouse for everyday tasks.

I have two extensions installed.  One is Enigmail, the other is called "Identity Chooser".  The latter makes it easier to choose an identity (from address) on my replies.  It is possible that the new version of Thunderbird doesn't interact correctly with one of my extensions.



Actual results:

Press Ctrl-R on a mailing list message with Reply-To header.  The Reply-To header is ignored, and the new message is addressed to the original sender of the message.


Expected results:

The value in the Reply-To header should have been used.
Yes, that changed in TB 52, refer to the release notes:
https://www.mozilla.org/en-US/thunderbird/52.0/releasenotes/
When replying to a mailing list, reply will be sent to address in From header ignoring Reply-to header.

Other than that, there has been a fierce discussion about this in bug 77304 where that got implemented.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 months ago
I think this new behavior is wrong, and is going to cause huge headaches for many users.  Just a few seconds ago, I discovered (after clicking Send) that I had sent a mailing list reply to one person instead of the mailing list.  I've been using Thunderbird in this way for many years.  It's going to be a real effort for me to re-train myself so replies are correct.

I also realize that my opinion may count for nothing.
Making all complaints a dupe of bug 1309486 now.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1309486
You need to log in before you can comment on or make changes to this bug.