Devtools ruler show decimal place

RESOLVED FIXED

Status

DevTools
Inspector
P3
normal
RESOLVED FIXED
a year ago
9 days ago

People

(Reporter: jkt, Unassigned, Mentored)

Tracking

({good-first-bug})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8871257 [details]
Selection_643.png

In dev tools I am seeing a decimal place for the y axis which doesn't seem to change and spans outside the box.

See attachment.
Probably missing some rounding in the code. This is the measurement tool, and the code for it is in: http://searchfox.org/mozilla-central/source/devtools/server/actors/highlighters/measuring-tool.js#297

On these lines, we should probably round the values before displaying them: http://searchfox.org/mozilla-central/source/devtools/server/actors/highlighters/measuring-tool.js#332-333

Matteo (:zer0) can mentor anyone who wants to get started on this bug, don't hesitate to ask questions.
Mentor: zer0
Keywords: good-first-bug
Priority: -- → P3

Comment 2

a year ago
Hi
I am interested in working on this bug. Please let me know if I can take this.
Flags: needinfo?(zer0)
Hi Ritwik, glad to hear! You can definitely take it, feel free to ask anything you need.
Assignee: nobody → ritwikabhishek
Flags: needinfo?(zer0)
Status: NEW → ASSIGNED
Ritwik, are you still interesting in fixing this?

Sebastian
Flags: needinfo?(ritwikabhishek)
(In reply to Sebastian Zartner [:sebo] from comment #4)
> Ritwik, are you still interesting in fixing this?

Doesn't seem so. Therefore I unassign Ritwik now, so somebody else can pick this up.
Having said that, I cannot reproduce this issue. Jonathan, what are the steps to reproduce this?

Sebastian
Assignee: ritwikabhishek → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(ritwikabhishek) → needinfo?(jkt)
(Reporter)

Comment 6

10 months ago
Could no longer replicate, lets close for now.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(jkt)
Resolution: --- → FIXED

Updated

9 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.