The entered characters disappeared when using Korean IME in Composer

NEW
Assigned to

Status

()

--
major
17 years ago
8 years ago

People

(Reporter: ruixu, Assigned: jshin1987)

Tracking

({inputmethod, intl})

Trunk
mozilla1.0.1
x86
Windows 2000
inputmethod, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [EDITORBASE-])

(Reporter)

Description

17 years ago
This bug is separated from bug 128562, and need more fix. 
The original report is from Yoon Kyung Koo as follows:

-------------------------
I tested again with 2002-04-09-10-trunk mozilla-win32-talkback.zip.
Still the new bug works.
My test environment is Korean Windows 2k sp2, Pentium III 750MHz, 192MB RAM.
And actually the IME is default IME(2bulsik) and half width input mode.

Steps.
1. start mozilla
2. click on composer icon in the status bar.
3. then now it should be focused in a blank composer window and the Korean IME
will be in English input mode.
4. type in 'a'
5. type in a space.
6. then press the Korean/English conversion key.
7. type in 'ka' a Korean character and a space 
then the Korean character and the space will disappear.
I suppose it occurs only the first time Korean characters are entered.

the input sequence is
'a(some English characters)'<space>'KA(any one Korean char)'<space>
then the result would be
'a'

------- Additional Comment -------
For those who don't understand Korean I'll make the steps clearer.
I meant 'KA' or 'ka' to represent a Korean character (which pronounces 'ka').
I'm sorry to confuse you. If you press 'k''a' keys in sequence, those makes two
Korean characters not one.
To key in that Korean character I've intended, you should press 'r''k' in 
sequence.
Any one Korean character will make that bug happen, so you need to just press
the 'r' key in Korean input mode.
(Reporter)

Updated

17 years ago
Keywords: intl
(Reporter)

Comment 1

17 years ago
cc -> jfrancis@netscape.com, kin@netscape.com

Comment 2

17 years ago
I have a win NT box.  Will it hapen there?  If so, if I could get some help on
setting up the right environment to reproduce the bug, then I will be happy to
help investigate.
(Reporter)

Comment 3

17 years ago
Yes, I just confirmed it is reproducible on US NT4 + Korean IME. I will go to 
your cube.
(Reporter)

Updated

17 years ago
Summary: The characters input disappeared when using Korean IME in Composer → The entered characters disappeared when using Korean IME in Composer
(Reporter)

Comment 4

17 years ago
Updates:
Double checked with 20020422 branch build, with the same repro steps in original 
report, after step 7, the Korean character is still displayed, but the space 
disappears.

Comment 5

17 years ago
assigning to joe.
Please let me know if you need my help.
Assignee: yokoyama → jfrancis

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: [EDITORBASE]
Target Milestone: --- → mozilla1.0

Comment 6

17 years ago
Roy, it sounds IME-specific. I'm assigning back to you, if this is not correct
(and maybe that is the case, since you assigned to Joe), please reassign as
appropriate.

Does this problem happen just in composer, or dies it also happen in text fields?

Comment 7

17 years ago
--> yokoyama
Assignee: jfrancis → yokoyama
Status: ASSIGNED → NEW

Comment 8

17 years ago
grabbing this back.  I'm working on it, believe it or not.  It's just taking a
long time to investigate.
Assignee: yokoyama → jfrancis

Comment 9

17 years ago
nominating nsbeta1.  disapearing text is pretty evil.
Status: NEW → ASSIGNED
Keywords: nsbeta1

Comment 10

17 years ago
yokoyama, could you please take a look at this one?
rui- does this happened on url bar?
Assignee: jfrancis → yokoyama
Status: ASSIGNED → NEW
(Reporter)

Comment 11

17 years ago
>> rui- does this happened on url bar?
No, it doesn't happen on url bar.

Comment 12

17 years ago
so the worst case is the one space got deleted. since korean currently is not
our target shipping place, nsbeta1- it. 
Keywords: nsbeta1 → nsbeta1-

Comment 13

17 years ago
moving milestone
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Whiteboard: [EDITORBASE] → [EDITORBASE-]

Comment 14

17 years ago
adding myself to the cc list since i keep getting this bug taken away from me.  :-)

My current theory is that we are getting a bad composition string from IME in
this scenario.  But that is preliminary. 

Comment 15

16 years ago
Mozilla for Linux build 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

still has this problem. But very hard to reproduce this bug and it
occurs time to time. ;-<

Comment 16

14 years ago
I think both roy and me are off mozilla for more than 2 years. If these bugs are
still here now, I think the real stauts is 'won't fix'. If you want to reopen
it, please find a new owner for it first. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 17

14 years ago
Mass Reassign Please excuse the spam
Assignee: tetsuroy → nobody

Comment 18

14 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 19

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
QA Contact: ruixu → i18n
Does somebody still have this problem? WFM?
You need to log in before you can comment on or make changes to this bug.