Images won't display anymore

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
5 months ago
5 months ago

People

(Reporter: David v.R. Bowles, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

Images stopped showing up suddenly. 


Actual results:

I tried to enable "show remote content", but this option has no effect. I see in the v. 52 release notes to enable "ail.compose.attach_http_images" - but have no idea where this is supposed to be done (command line? file?)


Expected results:

Images should have been displayed all along.

Comment 1

5 months ago
We really can't action "Images stopped showing up suddenly" :-(

This report doesn't have any detail whatsoever. Where did images stop showing up? When you view a received e-mail that contains embedded images? Maybe not.

As you know reading the release notes, we've made change to how images are included in a new e-mail composition. So is that where the problem is? Perhaps an image in the signature?

Please note: Bugzilla is NOT a support forum. It is a tracking system for bugs in Mozilla products.
This is a support question. You can get support here:
https://support.mozilla.org/en-US/products/thunderbird

I've seen a bazillion bugs related to the new behaviour, and they were all invalid, so is this one.

That said, if you give us some minimal details, we might be able to assist you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 months ago
I consider this a bug! Images suddenly stopped showing up in the viewer pane - in spite of the "Allow remote content" option being checked (Tools\Options\Privacy\Mail Content). I made no changes to options, and can't seem to change this (even by unchecking that option, restarting, checking it again, restarting...)

This applies to all images, on outgoing and incoming e-mails.

Finally, there is nothing on your support forum to address this issue, nor any instructions where to include the "mail.compose.attach_http_images" string.

Comment 3

5 months ago
The preference "mail.compose.attach_http_images" has to do with attaching images from http(s) resources that you include in an e-mail you're writing. It can be set in
Tools > Options, Advanced, General, Config editor.

But that has nothing to do with your problem. You're saying that you can't see images when viewing messages despite "Allow remote content" being checked.

First you need to understand how images in HTML e-mail work. Some of them are attached to the e-mail, others are fetched from the internet when viewing the message, that's the "remote content".

Can you run TB with all add-ons disabled (see Help menu) and check whether the problem persists.

And no, it's not a bug so far since this is the first report I've seen.
(Reporter)

Comment 4

5 months ago
I tried running in safe mode, but nothing has changed. Attached images aren't shown (just a text string when an image is attached, or hyperlinks for remote content).

Funnily enough, on another computer I have the same problem in Chrome! Images won't display in GMail or Google Photos.

Comment 5

5 months ago
Are you sure you haven't accidentally set: View > Message Body As > Plain Text?

What you wrote in comment #3 is really weird:
"just a text string when an image is attached, or hyperlinks for remote content". Can you upload a screenshot? Use "Attach File" above.
(Reporter)

Comment 6

5 months ago
Created attachment 8871367 [details]
screen capture of e-mail with remote content
(Reporter)

Comment 7

5 months ago
Created attachment 8871369 [details]
screen capture with attached image
(Reporter)

Comment 8

5 months ago
I've attached two screenshots, one with remote content and one with local content.

Comment 9

5 months ago
(In reply to Jorg K (GMT+2) from comment #5)
> Are you sure you haven't accidentally set: View > Message Body As > Plain
> Text?
Did you check this option?
(Reporter)

Comment 10

5 months ago
Funnily enough, some photos were displayed correctly, though not others. I looked, and indeed that setting had been changed. Perhaps toggling it back and forth (as well as inserting the "mail.compose.attach_http_images" string) seems to have resolved this. Thanks for your help!
You need to log in before you can comment on or make changes to this bug.