hidden extension updates show up in about:addons if open during update

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
4 months ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

unspecified
mozilla66
Points:
---

Firefox Tracking Flags

(firefox66 verified)

Details

(Whiteboard: triaged)

Attachments

(3 attachments, 1 obsolete attachment)

Assignee

Description

2 years ago
If about:addons is open when a background update happens, any hotfix or system add-on updates found show up. On refresh they go away.

System add-on updates are never uninstallable or user-disableable so there isn't a danger of users accidentally removing something important.
Assignee

Comment 1

2 years ago
I suspect the issue here is there is an install listener that isn't checking to see that an add-on is hidden.

The fact that this happens to hotfix too makes me think this is probably an old bug and so was overlooked for system add-on updates too.
Comment hidden (mozreview-request)
Assignee

Updated

2 years ago
Duplicate of this bug: 1367559

Comment 4

2 years ago
mozreview-review
Comment on attachment 8871348 [details]
Bug 1367800 - do not display hidden add-ons in about:addons during upgrades.

https://reviewboard.mozilla.org/r/142826/#review147138

I think we should also check if the add-on is hidden before adding the item, so they don't briefly show up during the download/install and then mysteriously disappear. r=me with that.
Attachment #8871348 - Flags: review+
Assignee

Comment 5

2 years ago
aswan points out that we do have browser tests for ensuring that hidden add-ons don't appear in the UI, so I will add some tests now (was going to defer it to a followup, when I thought we didn't have test coverage for this).

Updated

2 years ago
Whiteboard: triaged
Assignee

Updated

2 years ago
Attachment #8871348 - Flags: review?(aswan)

Comment 6

2 years ago
As I’ve said in the duplicate bug 1367559 comment 2, I’ve previously not had a screenshot of system add-ons in the Add-ons Manager.

After a recent system add-ons update, I finally got a screenshot of system add-ons in the Add-ons Manager, so I’m posting it here, because bug 1367559 is a duplicate of this bug.
Assignee

Updated

a year ago
Summary: hotfix and system add-on updates show up in about:addons if open during update → system add-on updates show up in about:addons if open during update
Assignee

Updated

a year ago
Duplicate of this bug: 1451618
Assignee

Updated

a year ago
Summary: system add-on updates show up in about:addons if open during update → hidden extension updates show up in about:addons if open during update

Let's land this! (paraphrasing kmaglione)

Flags: needinfo?(rhelmer)
Priority: -- → P1
Assignee

Updated

4 months ago
Attachment #8871348 - Attachment is obsolete: true
Flags: needinfo?(rhelmer)
Assignee

Comment 10

4 months ago

I tested this manually (reused the system add-on test set up in bug 1428459 comment 14) and I can reproduce this behavior by just leaving the add-ons manager open while add-on updates are running. The updates are hidden with the latest patch.

Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e80210429422f8aaafca1c5c36deaa5cff142387&selectedJob=223366973

Comment 11

4 months ago
Pushed by rhelmer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bce1b588653a
do not display hidden add-ons in about:addons during upgrades. r=kmag

Comment 12

4 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Comment 13

4 months ago

Verified as fixed on Windows 10x64 and macOS 10.13.6 using https://treeherder.mozilla.org/#/jobs?repo=try&revision=e80210429422f8aaafca1c5c36deaa5cff142387&selectedJob=223366973 .

I can confirm that I reproduced the bug on previous versions.

I will attach a postfix screenshot.

Status: RESOLVED → VERIFIED

Comment 14

4 months ago
You need to log in before you can comment on or make changes to this bug.