Print Preview uses the Zoom and shouldn't

VERIFIED FIXED in mozilla1.0

Status

()

Core
Printing: Output
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Max Alekseyev, Assigned: rods (gone))

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FIXED_ON_TRUNK], URL)

Attachments

(1 attachment)

3.44 KB, patch
dcone (gone)
: review+
rods (gone)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.9+) Gecko/20020409
BuildID:    2002040916

Mozilla always print 100% scaled text (no matter what Print Preview shows).

Reproducible: Always
Steps to Reproduce:
1. Go to given URL
2. Set View -> Text Zoom -> 50%
3. Go to File->Print Preview and see that all text takes 8 pages (in my case).
4. Push "Print" button and get 28 pages on the printer of 100% scaled text


Actual Results:  Text is printed unscaled. No correlation with what Print
Preview shows.

Comment 1

16 years ago
Happens on Windows as well.

Either print preview shouldn't scale, or we should print scaled.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Hardware: PC → All
(Reporter)

Comment 2

16 years ago
Changing scale in Print Preview takes no effect either.
So at the moment there is no way to print scaled text. ;(
(Assignee)

Comment 3

16 years ago
Looks like Print Preview takes into account Text Zooming and should or print
need to take into account text zooming
(Assignee)

Comment 4

16 years ago
Zoom/Text Zoom is for visually "zooming" the page in galley mode but is not
intended to to do anyhting for printing. Scaling in the the page setup is
intended for that.

The bug here is that PP obeys the TextZoom and should not.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Summary: Scaling has no effect on actually printed text → Print Preview uses the Zoom and shouldn't
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.0
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 6

16 years ago
Created attachment 78947 [details] [diff] [review]
patch

Cache the Zoom and TextZoom for the main DC while in Print Preview and then set
it back when leaving Print Preview

Comment 7

16 years ago
Comment on attachment 78947 [details] [diff] [review]
patch

r=dcone
Attachment #78947 - Flags: review+

Comment 8

16 years ago
Comment on attachment 78947 [details] [diff] [review]
patch

sr=attinasi
Attachment #78947 - Flags: review+ → superreview+

Updated

16 years ago
Attachment #78947 - Flags: superreview+ → review+
(Assignee)

Comment 9

16 years ago
Comment on attachment 78947 [details] [diff] [review]
patch

sett as sr per marc's sr comment
Attachment #78947 - Flags: superreview+
(Assignee)

Updated

16 years ago
Whiteboard: [FIXED_ON_TRUNK]
(Assignee)

Comment 10

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
adt: Fixing this bug is important in maintaining the user's confidence that
print preview is showing what the actual printed page will look like.
Keywords: adt1.0.0

Comment 12

16 years ago
verified on 4/16 trunk build.

Max, this should be working for you now..download latest build
to see fix....if not fixed, then REOPEN.
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
sujay, is there any reason why you think this might be reopened?
(Reporter)

Comment 14

16 years ago
Nice fix but not for the problem I tried to state. Mostly I worried about
ability to print scaled text. I didn't have it before, neither do now.

What I had before:
Print Preview showed scaled text but the was printed unscaled;

What I have now:
Print Preview doesn't scale text at all, and the text is still printed unscale.

Should I reopen this bug, or create a new burreport?
(Reporter)

Comment 15

16 years ago
Sorry for misprints in previous posting.

Nice fix but not for the problem I tried to state. Mostly I worried about
ability to print scaled text. I didn't have it before, neither do now.

What I had before:
Print Preview showed scaled text, but the text was printed unscaled;

What I have now:
Print Preview doesn't scale text at all, and the text is still printed unscaled.

Should I reopen this bug, or create a new bugreport?

Comment 16

16 years ago
filed bug 137984 for new issue.
(Assignee)

Comment 17

16 years ago
Zoom doesn't affect scaling zooming is only for the viewing of web pages not
printing. If you are trying to scal from Print Preview, first open the UI and
turn off "Shrink To Fit" the UI toolbar in PP should be disabled when Shrink TO
Fit is o. That bug has already been filed.

Comment 18

16 years ago
adding adt1.0.0+.  Please check into the branch as soon as possible and add
fixed1.0.0
Keywords: adt1.0.0 → adt1.0.0+
(Assignee)

Updated

16 years ago
Keywords: fixed1.0.0
(Assignee)

Comment 19

16 years ago
fixed on branch

Comment 20

16 years ago
verified in 4/23 branch build.
Keywords: verified1.0.0
You need to log in before you can comment on or make changes to this bug.