Closed Bug 1367892 (SQLite3.19.2) Opened 3 years ago Closed 3 years ago

Upgrade to SQLite 3.19.2

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: ionnv, Assigned: RyanVM)

References

()

Details

https://www.sqlite.org/news.html

https://www.sqlite.org/releaselog/3_19_2.html

"Still more problems have been found in the LEFT JOIN flattening optimization that was added in the 3.19.0 release. This patch release fixes all known issues with that optimization and adds new test cases. Hopefully this will be the last patch."
Depends on: SQLite3.19.1
Assignee: nobody → ryanvm
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
https://hg.mozilla.org/mozilla-central/rev/c24989a056d0
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Thank you for following this!

As a side note, we should go back to the good habit of waiting at least one week before upgrading after a release, since this is the kind of issues that habit was avoiding.
Heh, I was thinking the same thing. Point taken.
You need to log in before you can comment on or make changes to this bug.