Closed Bug 1367916 Opened 4 years ago Closed 4 years ago

Sidebar "all panels" URL points to netscape.com (404)

Categories

(SeaMonkey :: Sidebar, defect)

defect
Not set
normal

Tracking

(seamonkey2.52 fixed)

RESOLVED FIXED
seamonkey2.52
Tracking Status
seamonkey2.52 --- fixed

People

(Reporter: isaacschemm, Assigned: frg)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49
Build ID: 20170410193223



Actual results:

sidebar.customize.all_panels.url points to a RDF file at netscape.com that no longer exists


Expected results:

sidebar.customize.all_panels.url should be set to a blank string (for now), which will prevent SeaMonkey from checking it
Attachment #8871505 - Flags: review?(frgrahl)
With the current pref and without the patch if you try to customize the sidebar panel this is logged in the console. In the web console a 404 is also reported.

> Timestamp: 5/26/2017, 9:28:16 AM
> Error: XML Parsing Error: syntax error
> Location: http://sidebar-rdf.netscape.com/en-us/sidebar-rdf/0.1/all-panels.rdf
> Line Number 1, Column 50:
> Source File: http://sidebar-rdf.netscape.com/en-us/sidebar-rdf/0.1/all-panels.rdf
> Line: 1, Column: 50
> Source Code:
> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
Assignee: nobody → isaacschemm
Blocks: 411526
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8871505 [details] [diff] [review]
1367916-remove-sidebar-all-panels-url.patch

Drat that didn't work. The error does not go away and becomes even more obscure in the log.
Attachment #8871505 - Flags: review?(frgrahl) → review-
Isaac you know more about the sidebars than me. This gets rid of the error but removes the whole option. I was unable to find an alternative rdf website and I suspect not one will ever show up again. Customizing the sidebar with the gadgets from Ed Mullens site still works. Do you think it can be removed? I will ask for review then and take the bug.
Attachment #8872075 - Flags: feedback?(isaacschemm)
Comment on attachment 8872075 [details] [diff] [review]
1367916-remove-sidebar-all-panels-url-V2.patch

I think it's OK to remove the .rdf functionality, since nobody's maintaining one right now, and pages can have an "add to sidebar" link with window.sidebar.addPanel anyway. Plus, if someone wants to maintain an .rdf in the future it shouldn't be difficult to put the code back in.
Attachment #8872075 - Flags: feedback?(isaacschemm) → feedback+
Isaac, thanks for you help. I think too removing it is the best option for now. If a new rdf site pop up to code could be added back. I am taking the bug if it is ok with you.
Assignee: isaacschemm → frgrahl
Attachment #8871505 - Attachment is obsolete: true
Attachment #8872075 - Flags: review?(iann_bugzilla)
Comment on attachment 8872075 [details] [diff] [review]
1367916-remove-sidebar-all-panels-url-V2.patch

r=me
Attachment #8872075 - Flags: review?(iann_bugzilla) → review+
https://hg.mozilla.org/comm-central/rev/ad200b86b833c0250a221d2fada7b23dabe7d394
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.52
Duplicate of this bug: 411526
You need to log in before you can comment on or make changes to this bug.