Closed Bug 1367964 Opened 4 years ago Closed 4 years ago

If Nightly window is minimized, opening a locally stored html page will show as blank in the tab, until you detach and then reattach the tab to the window

Categories

(Firefox :: Tabbed Browser, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- verified

People

(Reporter: mayankleoboy1, Assigned: mconley)

References

Details

Attachments

(5 files, 2 obsolete files)

Attached file dd.rar (obsolete) —
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170525030225

Steps to reproduce:

0. Download and unzip the attachment somewhere  on your disk
1. Create a new profile
2. Start Firefox
3. double click on Index.html file (So that index.html opens in a new tab)


Actual results:

Intermittently, the new tab wont show anything. It is completely blank. 
However, if you move your mouse inside the page, the cursor will behave as if there is content in the page. (For the attachment, mouse pointer becomes the "hand" pointer). The moise will show tooltips etc.

The only way to show content is to detach the tab from the window. This will cause the page to " become visible"


Expected results:

not so

Tentatively, this is a regression from bug 132866
Attached image part1.png
mouse inside the window shows the tooltips, and the pointer looks like a hand-pointer
Component: Untriaged → Tabbed Browser
Attached image part2.png
Here, i am dragging the tab. The tab-drag-preview shows the outline of the page.
I meant bug 1362866
tentative ni?
Flags: needinfo?(mconley)
This is on Windows10x64
And this bug is not restricted to opening a locally stored file. I reproduced it with a Pushbullet notification that opens a URL in a new background tab
(In reply to Mayank Bansal from comment #1)
> Created attachment 8871585 [details]
> part1.png
> 
> mouse inside the window shows the tooltips, and the pointer looks like a
> hand-pointer

Which essentially means that the page has successfully loaded with all the JS/CSS etc, it is just not visible.
Summary: After loading a page, nothing is shown in the tab, until you detach and then reattach the tab to the window → If Nightly window is minimized, a locally stored html page will not show anything in the tab, until you detach and then reattach the tab to the window
Summary: If Nightly window is minimized, a locally stored html page will not show anything in the tab, until you detach and then reattach the tab to the window → If Nightly window is minimized, opening a locally stored html page will show as blank in the tab, until you detach and then reattach the tab to the window
100% Reproducible STR:

0. Download and unzip the attachment somewhere  on your disk
1. Create a new profile
2. Start Firefox
2.5 Minimize the nightly window (by clicking on the minimize button on the top right corner, the usual method to minimize any window on Windows)
3. double click on Index.html file (So that index.html opens in a new tab)

ER: HTML page is rendered
AR: Blank page until you detach the tab, and then attach it back
Attached file title.html
In fact, you dont need any fancy HTML page. This html is enough to reproduce the issue
confirmed by Mozregression:


6:54.15 INFO: Last good revision: 6d4744a6c81c498cc81cad11b4ead64660a3d269
 6:54.15 INFO: First bad revision: aa48bb3f494410de514041e8c06ca15c38680181
 6:54.15 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6d4744a6c81c498cc81cad11b4ead64660a3d269&tochange=aa48bb3f494410de514041e8c06ca15c38680181

 6:56.82 INFO: Looks like the following bug has the  changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1362866
Blocks: 1362866
Attached file index.html (obsolete) —
The index.html file from the rar file.
Comment on attachment 8871828 [details]
index.html

Bah, apparently, the page depends on the other files in the rar.
Attachment #8871828 - Attachment is obsolete: true
Attached file dd.zip
I've recompressed the files in dd.rar into dd.zip so that I don't have to install another archiving tool on my desktop machine.
Attachment #8871584 - Attachment is obsolete: true
As I said in comment 7, any HTML file will do.
This is reproducible with title.html also (attached last)
No luck reproducing this on my Windows machines. :(

Mayank Bansal, can you do me a favour, and create the new bool pref in about:config:

browser.tabs.remote.logSwitchTiming

and set it to true

and then restart, and reproduce the issue. Once reproduced, can you then open the Browser Console via Ctrl-Shift-J, and paste me its contents?
Flags: needinfo?(mconley) → needinfo?(mayankleoboy1)
See comment 6 for 100% repro STR (for me, anyway)
(I did a bunch of stuff while getting the log. relevant output should be near the end. File loaded is called "title.html" )

*********************************************Output******************************************


5/26/2017, 10:12:10 PM - Signed 
in with API key tjkqiXaJxd6dCBC56OHTZgmbFZrIgVUj  pb.js:39:9
5/26/2017, 10:12:10 PM - Bootstrapping...  pb.js:39:9
5/26/2017, 10:12:10 PM - Connecting to server via WebSocket  pb.js:39:9
5/26/2017, 10:12:11 PM - Dismissed e2e  pb.js:39:9
5/26/2017, 10:12:13 PM - WebSocket onopen  pb.js:39:9
"5/26/2017, 10:12:13 PM - POST https://api.pushbullet.com/v2/sync"  pb.js:39:9
5/26/2017, 10:12:13 PM - Received message:  pb.js:39:9
Object { type: "nop" }  pb.js:39:9
5/26/2017, 10:12:14 PM - Saving pushes  pb.js:39:9
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:5:18068
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:5:18272
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:5:19514
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:5:19677
Expected color but found ‘top’.  Error in parsing value for ‘background’.  Declaration dropped.  search:5:20071
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:5:20099
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:5:20257
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:5:20346
Expected color but found ‘top’.  Error in parsing value for ‘background’.  Declaration dropped.  search:5:20517
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:5:20545
Expected end of value but found ‘main-size’.  Error in parsing value for ‘flex’.  Declaration dropped.  search:5:22638
Expected media feature name but found ‘-webkit-min-device-pixel-ratio’.  search:5:22951
Expected media feature name but found ‘min-device-pixel-ratio’.  search:5:22989
Expected end of value but found ‘main-size’.  Error in parsing value for ‘flex’.  Declaration dropped.  search:5:23333
Expected end of value but found ‘main-size’.  Error in parsing value for ‘flex’.  Declaration dropped.  search:5:23462
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:5:23943
Expected end of value but found ‘main-size’.  Error in parsing value for ‘flex’.  Declaration dropped.  search:5:24701
Expected end of value but found ‘0’.  Error in parsing value for ‘-moz-box-flex’.  Declaration dropped.  search:5:25374
Unknown pseudo-class or pseudo-element ‘-webkit-scrollbar’.  Ruleset ignored due to bad selector.  search:5:25464
Unknown pseudo-class or pseudo-element ‘-webkit-scrollbar-button’.  Ruleset ignored due to bad selector.  search:5:25514
Unknown pseudo-class or pseudo-element ‘-webkit-scrollbar-thumb’.  Ruleset ignored due to bad selector.  search:5:25565
Unknown pseudo-class or pseudo-element ‘-webkit-scrollbar-thumb’.  Ruleset ignored due to bad selector.  search:5:25782
Expected media feature name but found ‘-o-min-device-pixel-ratio’.  search:6:338
Expected media feature name but found ‘-webkit-min-device-pixel-ratio’.  search:6:370
Expected media feature name but found ‘min-device-pixel-ratio’.  search:6:408
Expected media feature name but found ‘-o-min-device-pixel-ratio’.  search:7:340
Expected media feature name but found ‘-webkit-min-device-pixel-ratio’.  search:7:372
Expected media feature name but found ‘min-device-pixel-ratio’.  search:7:410
Error in parsing value for ‘-moz-transition’.  Declaration dropped.  search:8:4122
Unknown property ‘user-select’.  Declaration dropped.  search:8:4395
Unknown property ‘-moz-text-overflow’.  Declaration dropped.  search:8:4939
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:8:8995
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:8:9298
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:9728
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:8:9821
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:8:9941
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:10157
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:10376
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:10675
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:10816
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:10956
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:11193
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:11385
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:11576
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:11763
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:11799
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:12010
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:12046
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:8:12260
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:12315
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:8:12798
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:13053
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:13209
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:15180
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:15781
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:18201
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:8:18368
Unknown property ‘-moz-tap-highlight-color’.  Declaration dropped.  search:47:4765
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:47:5799
Unknown property ‘-moz-tap-highlight-color’.  Declaration dropped.  search:47:72
Unknown property ‘tap-highlight-color’.  Declaration dropped.  search:47:106
Unknown property ‘zoom’.  Declaration dropped.  search
Error in parsing value for ‘display’.  Declaration dropped.  search:53:2603
Unknown property ‘-moz-order’.  Declaration dropped.  search:53:2663
Unknown property ‘-moz-tap-highlight-color’.  Declaration dropped.  search:53:8931
Unknown pseudo-class or pseudo-element ‘-moz-autofill’.  Ruleset ignored due to bad selector.  search:53:11327
Error in parsing value for ‘display’.  Declaration dropped.  search:53:14110
Unknown property ‘-moz-tap-highlight-color’.  Declaration dropped.  search:53:18747
Unknown property ‘tap-highlight-color’.  Declaration dropped.  search:53:18781
Unknown property ‘-moz-tap-highlight-color’.  Declaration dropped.  search:54:1104
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:718
Expected color but found ‘top’.  Error in parsing value for ‘background’.  Declaration dropped.  search:369:888
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:369:916
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:1045
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:1137
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:1259
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:1430
Expected color but found ‘top’.  Error in parsing value for ‘background’.  Declaration dropped.  search:369:1601
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:369:1629
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:2808
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:2912
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:3028
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:3198
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:3531
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:3648
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:3807
Expected color but found ‘top’.  Error in parsing value for ‘background’.  Declaration dropped.  search:369:3970
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:369:3998
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:4134
Expected color but found ‘top’.  Error in parsing value for ‘background’.  Declaration dropped.  search:369:4506
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:369:4534
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:4665
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:5564
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:7013
Expected media feature name but found ‘-webkit-min-device-pixel-ratio’.  search:369:8093
Expected media feature name but found ‘min-device-pixel-ratio’.  search:369:8131
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:369:9784
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:9916
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:369:10029
Expected color but found ‘top’.  Error in parsing value for ‘background-image’.  Declaration dropped.  search:369:10288
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:10487
Expected ‘none’, URL, or filter function but found ‘progid’.  Error in parsing value for ‘filter’.  Declaration dropped.  search:369:10521
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:10683
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:11186
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:11583
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:11905
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:12359
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:12397
Error in parsing value for ‘width’.  Declaration dropped.  search:369:13829
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:14244
Unknown property ‘-moz-border-radius’.  Declaration dropped.  search:369:14552
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  search:369:14590
Expected media feature name but found ‘-webkit-min-device-pixel-ratio’.  search:369:16983
Expected media feature name but found ‘min-device-pixel-ratio’.  search:369:17021
Expected media feature name but found ‘-webkit-min-device-pixel-ratio’.  search:369:17381
Expected media feature name but found ‘min-device-pixel-ratio’.  search:369:17419
Error: When not using *.example.org wildcard, the string supplied is expected to be either an exact URL to match or a URL prefix. The provided string ('firefoxux.github.io') is unlikely to match any pages.  match-pattern.js:46:15
Expected declaration but found ‘*’.  Skipped to next declaration.  87f46ba9c3d9ec1891ddddb29887590f.css:2:1157
Expected declaration but found ‘*’.  Skipped to next declaration.  87f46ba9c3d9ec1891ddddb29887590f.css:2:1179
Unknown property ‘zoom’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:2:4989
Expected ‘none’, URL, or filter function but found ‘alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:2:5232
Expected declaration but found ‘*’.  Skipped to next declaration.  87f46ba9c3d9ec1891ddddb29887590f.css:2:6607
Expected declaration but found ‘*’.  Skipped to next declaration.  87f46ba9c3d9ec1891ddddb29887590f.css:2:6639
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:515
Unknown property ‘user-select’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:2116
Expected ‘none’, URL, or filter function but found ‘alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:12171
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:18292
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:18442
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:18517
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:20:29160
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:22:515
Unknown property ‘user-select’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:22:2116
Expected ‘none’, URL, or filter function but found ‘alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:22:12171
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:24:2878
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:24:3028
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:24:3103
Expected ‘none’, URL, or filter function but found ‘Alpha(’.  Error in parsing value for ‘filter’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:24:13746
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:26:223
Unknown property ‘user-select’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:26:571
Unknown property ‘user-select’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:26:808
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:32:4598
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:32:14268
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  87f46ba9c3d9ec1891ddddb29887590f.css:32:14862
Expected color but found ‘border’.  Error in parsing value for ‘text-decoration’.  Declaration dropped.  show_bug.cgi:1:1377
Unknown property ‘-moz-border-radius’.  Declaration dropped.  show_bug.cgi:1:1679
Expected color but found ‘-moz-use-text-color’.  Error in parsing value for ‘border-color’.  Declaration dropped.  show_bug.cgi:1:3474
Unknown property ‘-moz-border-radius’.  Declaration dropped.  show_bug.cgi:1:5135
Unknown property ‘-moz-border-radius’.  Declaration dropped.  show_bug.cgi:1:5429
Unknown property ‘-moz-border-radius’.  Declaration dropped.  show_bug.cgi:1:6181
Unknown property ‘-moz-border-radius’.  Declaration dropped.  show_bug.cgi:1:6793
Unknown property ‘-moz-box-shadow’.  Declaration dropped.  show_bug.cgi:1:7030
5/26/2017, 10:12:40 PM - Not reporting alive from dev installation  pb.js:39:9
Object { name: "alive", signed_in: true, language: "en-US", clipboard_sync: false, e2e_enabled: false }  analytics.js:8:9
Error in parsing value for ‘width’.  Declaration dropped.  show_bug.cgi
5/26/2017, 10:12:43 PM - Received message:  pb.js:39:9
Object { type: "nop" }  pb.js:39:9
START
requestTab 1(about:blank) 0:VR(-) 1:(-) 
Tab should be blank: true
Requested tab is remote?: true
Switch to tab 1 - 1(about:blank)
DEBUG: tab switch time = 7
FINISH
done 0:(-) 1:VRB(-) 
Use of nsIFile in content process is deprecated.  loader.js:247:15
Error: When not using *.example.org wildcard, the string supplied is expected to be either an exact URL to match or a URL prefix. The provided string ('firefoxux.github.io') is unlikely to match any pages.  match-pattern.js:46:15
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.  title.html
Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode”  browser.xul
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”  browser.xul
Property contained reference to invalid variable.  Error in parsing value for ‘background-color’.  Falling back to ‘initial’.  webconsole.css:406:9402
Property contained reference to invalid variable.  Error in parsing value for ‘border-top-color’.  Falling back to ‘initial’.  webconsole.css:407:9459
Property contained reference to invalid variable.  Error in parsing value for ‘border-top-style’.  Falling back to ‘initial’.  webconsole.css:407:9459
Property contained reference to invalid variable.  Error in parsing value for ‘border-top-width’.  Falling back to ‘initial’.  webconsole.css:407:9459
Property contained reference to invalid variable.  Error in parsing value for ‘background-image’.  Falling back to ‘initial’.  webconsole.css:444:10354
Property contained reference to invalid variable.  Error in parsing value for ‘border-bottom-width’.  Falling back to ‘initial’.  widgets.css:85:2908
Property contained reference to invalid variable.  Error in parsing value for ‘border-top-width’.  Falling back to ‘initial’.  widgets.css:84:2850
Property contained reference to invalid variable.  Error in parsing value for ‘min-height’.  Falling back to ‘initial’.  widgets.css:82:2742
Property contained reference to invalid variable.  Error in parsing value for ‘margin-bottom’.  Falling back to ‘initial’.  widgets.css:87:3041
Property contained reference to invalid variable.  Error in parsing value for ‘margin-top’.  Falling back to ‘initial’.  widgets.css:86:2972
5/26/2017, 10:13:13 PM - Received message:  pb.js:39:9
Object { type: "nop" }  pb.js:39:9
START
Initial tab is loaded?: true
requestTab 0(https://bugzilla.mozilla.org/show_bug.cgi?id=1367964) 0:(-) 1:VR(+) 
Loading tab 0(https://bugzilla.mozilla.org/show_bug.cgi?id=1367964)
Tab should be blank: false
Requested tab is remote?: true
done 0:LR(+?) 1:V(+) 
onLayersReady(0, true) 0:LR(+?) 1:V(+) 
DEBUG: tab switch time = 33
Tab should be blank: false
Requested tab is remote?: true
Switch to tab 0 - 0(https://bugzilla.mozilla.org/show_bug.cgi?id=1367964)
done 0:VR(+) 1:(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:VR(+) 1:(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:VR(+) 1:(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:VR(+) 1:(+) 
onUnloadTimeout 0:VR(+) 1:(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:VR(+) 1:(-?) 
onLayersCleared(1) 0:VR(+) 1:(-?) 
Tab should be blank: false
Requested tab is remote?: true
FINISH
done 0:VR(+) 1:(-) 
TypeError: parentDocShell.getDocShellEnumerator is not a function[Learn More]  tab.js:62:23
START
Initial tab is loaded?: true
requestTab 1(file:///C:/Users/Mayank/Desktop/dd/title.html) 0:VR(+) 1:(-) 
Loading tab 1(file:///C:/Users/Mayank/Desktop/dd/title.html)
Tab should be blank: false
Requested tab is remote?: true
done 0:V(+) 1:LR(+?) 
onLayersReady(1, true) 0:V(+) 1:LR(+?) 
DEBUG: tab switch time = 28
Tab should be blank: false
Requested tab is remote?: true
Switch to tab 1 - 1(file:///C:/Users/Mayank/Desktop/dd/title.html)
done 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(+) 1:VR(+) 
onUnloadTimeout 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(-?) 1:VR(+) 
onLayersCleared(0) 0:(-?) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
FINISH
done 0:(-) 1:VR(+) 
5/26/2017, 10:13:43 PM - Received message:  pb.js:39:9
Object { type: "nop" }  pb.js:39:9
Flags: needinfo?(mayankleoboy1)
Thanks Mayank Bansal. Here's the relevant part of the log:

START
Initial tab is loaded?: true
requestTab 1(file:///C:/Users/Mayank/Desktop/dd/title.html) 0:VR(+) 1:(-) 
Loading tab 1(file:///C:/Users/Mayank/Desktop/dd/title.html)
Tab should be blank: false
Requested tab is remote?: true
done 0:V(+) 1:LR(+?) 
onLayersReady(1, true) 0:V(+) 1:LR(+?) 
DEBUG: tab switch time = 28
Tab should be blank: false
Requested tab is remote?: true
Switch to tab 1 - 1(file:///C:/Users/Mayank/Desktop/dd/title.html)
done 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(+) 1:VR(+) 
onUnloadTimeout 0:(+) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
done 0:(-?) 1:VR(+) 
onLayersCleared(0) 0:(-?) 1:VR(+) 
Tab should be blank: false
Requested tab is remote?: true
FINISH

So here, we're attempting to select tab 1 (title.html), and we determine that the tab should not be blank and that it's remote... 28ms later, we get its layers sent up, and we apparently complete the switch. We then unload the first tab, and we're done.

Are you _absolutely_ sure that you cannot reproduce this before bug 1362866 landed? Because at least according to the log, in the tab switch where you experienced the bug, we didn't even do any of the "blanking" stuff that bug 1362866 introduced.

If you _are_ able to reproduce this in a build from before bug 1362866 landed, this sounds a lot like bug 1364563 to me.
Flags: needinfo?(mayankleoboy1)
can you point me to the Windowsx64 build/nightly, exactly prior to when bug 1362866 landed? I can test that
(I really dont want to do a regression again. Using mozregression on this bug was painful)
Flags: needinfo?(mayankleoboy1) → needinfo?(mconley)
I can reproduce this bug with the build of comment 17 (buildid: 20170523150229)
So my mozregression range was bad :(
Flags: needinfo?(mayankleoboy1) → needinfo?(mconley)
Bah! Mayank, I'm so sorry - two new pieces of information:

1) I can reproduce your issue
2) The build I gave you was the wrong one, and still had my patches in it

Now that I've reproduced the issue, it does indeed look like the tab is still "blank", and that bug 1362866 is at fault.

Sorry for the runaround, and thanks for reporting!
Assignee: nobody → mconley
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(mconley)
OS: Unspecified → All
Hardware: Unspecified → x86
no problem :)
Comment on attachment 8871857 [details]
Bug 1367964 - Skip async tab switching blank tab optimization when the window is minimized.

https://reviewboard.mozilla.org/r/143362/#review147100
Attachment #8871857 - Flags: review?(wmccloskey) → review+
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c72b350230aa
Skip async tab switching blank tab optimization when the window is minimized. r=billm
https://hg.mozilla.org/mozilla-central/rev/c72b350230aa
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Flags: qe-verify+
I have reproduce this issue using an old Nightly from 2017-05-25.

This issue is verified fixed on 55.0b2 (20170615133456) under Windows 10 x64, Ubuntu 16.04 x64 LTS and Mac OS X 10.11.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.