Use more appropriate way to decide whether need to release decoder resource

RESOLVED FIXED in Firefox 57

Status

()

defect
P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: alwu, Assigned: alwu)

Tracking

unspecified
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

59 bytes, text/x-review-board-request
jwwang
: review+
Details
Assignee

Description

2 years ago
In bug1367980, we always use the same decoder even the decoding ended.

However, we could use more appropriate way to detect whether need to release the decoder. eg. if video is looping, we could use same decoder, otherwise, release the resource.

Also need to add ref-test to avoid regression.
(In reply to Alastor Wu [:alwu][please needinfo? me][7/26-8/3 PTO] from comment #0)
> In bug1367980, we always use the same decoder even the decoding ended.
> 
> However, we could use more appropriate way to detect whether need to release
> the decoder. eg. if video is looping, we could use same decoder, otherwise,
> release the resource.
JW, 
IIRC, you fixed a similar bug like this, right?
Flags: needinfo?(jwwang)
Priority: -- → P3
Assignee

Comment 2

2 years ago
I'll revert the change in bug1367980, because JW has already done what I want to implement in bug1371202.
Flags: needinfo?(jwwang)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 6

2 years ago
mozreview-review
Comment on attachment 8887393 [details]
Bug 1367983 - correct comment.

https://reviewboard.mozilla.org/r/158244/#review165554
Attachment #8887393 - Flags: review?(jwwang) → review+

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/42667c5ba946
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
backed out on request in https://bugzilla.mozilla.org/show_bug.cgi?id=1383673#c3
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

2 years ago
Backout by cbook@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/a2058025fd77
Backed out changeset 42667c5ba946 for causing bug 1383673
Comment hidden (mozreview-request)

Comment 14

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/629a306d41e0
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.