Full URL copy problem when url contain Persian characters

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
RESOLVED WONTFIX
11 months ago
11 months ago

People

(Reporter: Saad Shamsaee, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170526030203

Steps to reproduce:

When i go to a address that contained Persian text in url...


Actual results:

if i select and copy a part of url, it will be paste true, like this:
http://dotnetboy.ir/post/اعتماد-به-نفس-در-انسان-ژنتیکی-اس

but if i select and copy all if url in address bar, it will be paste such:
http://dotnetboy.ir/post/%D8%A7%D8%B9%D8%AA%D9%85%D8%A7%D8%AF-%D8%A8%D9%87-%D9%86%D9%81%D8%B3-%D8%AF%D8%B1-%D8%A7%D9%86%D8%B3%D8%A7%D9%86-%DA%98%D9%86%D8%AA%DB%8C%DA%A9%DB%8C-%D8%A7%D8%B3%D8%AA


Expected results:

why?

Updated

11 months ago
Component: Untriaged → Location Bar
(Reporter)

Updated

11 months ago
Summary: Full URL copy problem → Full URL copy problem when url contain Persian characters
The urls are copied encoded because some software are not compatible with decoded urls.
Fwiw, the encoded url works yet.
if you want the url to be copied as-is you can set the browser.urlbar.decodeURLsOnCopy pref in about:config
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

11 months ago
(In reply to Marco Bonardo [::mak] from comment #1)
> The urls are copied encoded because some software are not compatible with
> decoded urls.
> Fwiw, the encoded url works yet.
> if you want the url to be copied as-is you can set the
> browser.urlbar.decodeURLsOnCopy pref in about:config

Thanks guy.
You need to log in before you can comment on or make changes to this bug.