error messages spewing at 60/s for CreateBuffer failures

NEW
Unassigned

Status

()

Core
Graphics
P3
normal
7 months ago
5 months ago

People

(Reporter: jesup, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Created attachment 8871779 [details]
about:support info for gfx

Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Failed 2 buffer db=0 dw=0 for 2955, 53, 599, 213 (t=54.7004) |[C12325081][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 335 (t=51096.7) |[C12325082][GFX1-]: Failed 2 buffer db=0 dw=0 for 344, 130, 970, 90 (t=51096.7) |[C12325083][GFX1-]: Failed 2 buffer db=0 dw=0 for 418, 515, 120, 2 (t=51096.7) |[C12325084][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312 (t=51096.7) |[C12325085][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312 (t=51096.7) |[C12325086][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 335 (t=51096.7) |[C12325087][GFX1-]: Failed 2 buffer db=0 dw=0 for 344, 130, 970, 90 (t=51096.7) |[C12325088][GFX1-]: Failed 2 buffer db=0 dw=0 for 418, 515, 120, 2 (t=51096.7) |[C12325089][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312 (t=51096.7) |[C12325090][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312 (t=51096.7) |[C12325091][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 335 (t=51096.7) |[C12325092][GFX1-]: Failed 2 buffer db=0 dw=0 for 344, 130, 970, 90 (t=51096.7) |[C12325093][GFX1-]: Failed 2 buffer db=0 dw=0 for 418, 515, 120, 2 (t=51096.7) |[C12325094][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312 (t=51096.7) |[C12325095][GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312 (t=51096.7) [GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 360, 312

From the end of the run

Linux Fedora 25 x64; Lenovo desktop Thinkstation 7100(?)

milan	jesup, bas, yeah, that's from RotatedContentBuffer::BeginPaint - not sure why we have so many and what kind of trouble you're running into, but it looks like it was a long-ish session, and if you were trying to break things, I can see having this many (60/s) messages show up
jesup:  Started after update to new m-c build on 5/23;previous build was 5/13
milan	:jesup - yeah, not sure what to make of it.  no hardware acceleration, CreateBuffer fails with reasonably small buffer sizes, which would suggest not being able to allocate a 32k buffer two minutes into the run
Whiteboard: gfx-noted
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.