Wrong comparison directive in bug_form.pl

RESOLVED DUPLICATE of bug 136751

Status

()

P3
trivial
RESOLVED DUPLICATE of bug 136751
17 years ago
6 years ago

People

(Reporter: andreas.hoefler, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
Line 289 in bug_form.pl:
    $bug{'qa_contact'} = $bug{'qa_contact'} > 0 ? 

Shouldn't this be:
    $bug{'qa_contact'} = $bug{'qa_contact'} gt '0' ? 

or something like that? (I'm not very familiar with perl yet)

Currently it seems to cause error-messages in apace:
[Thu Apr 11 08:06:54 2002] show_bug.cgi: Argument "" isn't numeric in numeric gt
(>) at (eval 10) line 9.
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.16
Are you sure it's that line of code producing the error? Perl translates on the
fly between strings representing numbers and the number themselves; the sort of
thing which produces that error is 

if (247 > "foo") {
...

Gerv
can you print the value of $bug{'qa_contact'} ?
(Reporter)

Comment 3

17 years ago
Im not 100% sure if it is THAT line, which causes the error, coz im not very
experienced with perl (and templates) but I found the error in my error_log and
looked over every file which has something to do with show_bug.cgi.

And this line seemed highly suspiciously to me.

The qa-contact-feature is turned on in my bz-install, although I have not
entered any users yet as qa-contacts...
I can't reproduce this, with or without qa contacts enabled. When is your CVS
bugzilla from?
(Reporter)

Comment 5

17 years ago
updated yesterday morning...
Can you add to globals.pl, in the Template->new call:

COMPILE_EXT => ".ttc",

as one of the hash values? The rerun the script. The error message will now
refer to a real file - paste the line it mentions, and about 5 lines each side.
Mention the line #, too.

Afterwards, remove that line, and the ..tc file in teh template/default
directory, otherwise it will cause problmes when precompiled tmeplates are
tunred on correctly.
Dupe of bug 136751, from looking at compiled templates (I think; if you can
reproduce this with that bug fix, please reopen)

*** This bug has been marked as a duplicate of 136751 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
clearing target milestone on invalid/duplicate/worksforme/wontfix bugs so
they'll show up as untriaged if they get reopened.
Target Milestone: Bugzilla 2.16 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.