ui.popup.disable_autohide set to true is preventing context menu dismissal on Nightly

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: caspy77, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
A Nightly user on IRC reported to me that after right clicking a page the context menu would not dismiss if they clicked elsewhere on the page.  They discovered that the cause was setting ui.popup.disable_autohide to true.
I tested this out and can confirm the behavior.

They indicated this issue had been present in Nightly for four days.

Comment 1

2 years ago
This is expected, and works the same way in 54 beta. I don't think it's a regression - the pref is literally for that specific purpose (to make it easier to debug panels and context menus). You can control the pref with the button in the top-right of the browser toolbox that looks like 4 little squares. See also: bug 1251658.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.