Closed Bug 1368281 Opened 3 years ago Closed 3 years ago

Identity popup is cut off

Categories

(Firefox :: Site Identity, defect, P1, minor)

55 Branch
x86
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: Adrian.Tiefenbrunner, Assigned: johannh)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image cut-off-info.png
What did you do?

1. Visit any website (e.g. bugzilla.mozilla.org).
2. Click on the page information button in the address bar.


What happened?

Page information box is cut off at the bottom (at the permissions part).


What should have happened?

Page info box should fully display all contents and show a bit of padding at the bottom.
Happens with the current 2017-05-27 Nightly, the 2017-05-26 one and I think the 2017-05-25 one too.
I don't have the shield on BMO with Nightly. Any website to have a large page information panel?
Attached image Tracking-Protection.PNG
The shield comes from the tracking protection, which is enabled by default in the private browsing mode. I have it enabled everywhere. You can either open a new private window and visit any website, or enable tracking protection everywhere.
Then you should be able to reproduce the behavior.
I tried with FF55 and resolution at 100/125%, I can't reproduce it. I think it's related to your locale (DE) which displays some text on 2 lines in the identity panel.
Component: Page Info Window → Site Identity and Permission Panels
Thanks for reporting!

Can you confirm that this only occurs in Nightly and not in e.g. Beta or Release?
Flags: needinfo?(Adrian.Tiefenbrunner)
Summary: Page information box is cut off → Identity popup is cut off
Ok it's happening to me, too. I think I can reliably reproduce it when the tracking protection button is shown. Paolo, do you think this regressed with bug 1009116?
Flags: needinfo?(Adrian.Tiefenbrunner) → needinfo?(paolo.mozmail)
(In reply to Johann Hofmann [:johannh] from comment #8)
> Paolo, do you think this regressed with bug 1009116?

Yes, and the solution is to turn the <label> elements in the section into <description> elements (and update the styling rules). I can review a patch that does this quickly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(paolo.mozmail)
Sounds good, I'll do it then.
Assignee: nobody → jhofmann
Blocks: 1009116
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 8872617 [details]
Bug 1368281 - Consistently use label and description in the tracking protection section of the identity popup.

https://reviewboard.mozilla.org/r/144160/#review147986

Thanks for fixing the permissions area margin as well!
Attachment #8872617 - Flags: review?(paolo.mozmail) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b71563f27958
Consistently use label and description in the tracking protection section of the identity popup. r=Paolo
https://hg.mozilla.org/mozilla-central/rev/b71563f27958
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
I have reproduced this Bug on Nightly 55.0a1 (2017-05-27)  on Windows 10, 64 Bit!

The bug's fix is now verified on latest  Nightly 55.0a1

Build ID 	20170601030206
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170531]
Thanks!
Status: RESOLVED → VERIFIED
Let's make sure this works as intended on Mac and Linux as well. Flagging for additional regression testing.
Flags: qe-verify+
I have managed to reproduce the issue mentioned in comment 0 with Firefox Nightly 55.0a1 (Build Id:20170527030204).

I can confirm that this issue is verified fixed on Firefox Nightly 55.0a1 (Build Id:20170612030208) using Windows 10 64 bit, MacOS 10.11.6 and Ubuntu 16.04 64bit. 

Thanks Saddam!
Flags: qe-verify+
See Also: → 1398963
You need to log in before you can comment on or make changes to this bug.