[Location Bar] The (new) hover highlight in grey should be hidden until the user moves the mouse the first time

RESOLVED DUPLICATE of bug 1357533

Status

()

RESOLVED DUPLICATE of bug 1357533
2 years ago
2 years ago

People

(Reporter: mehmet.sahin, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170527030204

Steps to reproduce:

Nightly 55.0a1 (2017-05-27) (64-Bit)
Mac OS 10.12.5

STR:
1.) Open a new window
2.) Place the mouse cursor below the Location Bar, where the Result List Drop Down appears.
3.) Press CMD-L to focus the Location Bar
4.) Type some thing into the Location Bar


Actual results:

The Result List Drop Down appears and the (new) hover highlight in grey appears, where the mouse cursor was placed in step 2.


Expected results:

The (new) hover highlight in grey should be hidden until the user moves the mouse the first time after the result list appears. 

Chrome is going this way and is hiding the hover highlight until the user moves the mouse the first time after the result list appears.

If you need more information, please let me know.

Thanks in advance.
(Reporter)

Updated

2 years ago
Component: Untriaged → Location Bar

Comment 1

2 years ago
I don't see this behavior like an issue, the grey overlay appears where the mouse position is over the location bar dropdown, whatever if the user has moved the mouse or not.
(Reporter)

Comment 2

2 years ago
Yes, but when you type, the mouse cursor is hidden, so then the hover should be hidden too. Chrome is doing it right. So I think Nighly is doing it wrong atm. Thanks.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357533
You need to log in before you can comment on or make changes to this bug.