"send to device" subview on page action menu should indicate the tab was sent

RESOLVED FIXED in Firefox 55

Status

()

Firefox
Sync
P1
normal
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: markh, Assigned: eoger)

Tracking

Trunk
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
STR:
* "send to device" subview, then click on a device to send the tab to.

Expected:
* The UI updates to reflect that some action was taken.

Actual:
* The UI doesn't change at all. The user may assume they mis-clicked, and click multiple times.

While this doesn't actually cause the tab to be sent multiple times, it does seem odd and may give the user the impression that the feature hasn't worked.

ISTM the subview should change to some text saying something like "Nice! The tab is on its way to {device name}". I don't believe there are any error states we need to reflect (ie, displaying "it worked" would be unconditional)
(Assignee)

Comment 1

5 months ago
rfeeley: for now we can just close the page action menu. We can do something fancier later.
Comment hidden (mozreview-request)
(Assignee)

Updated

5 months ago
Assignee: nobody → eoger
Status: NEW → ASSIGNED
Priority: -- → P1
(Reporter)

Comment 3

5 months ago
mozreview-review
Comment on attachment 8873135 [details]
Bug 1368384 - Close the page action menu when sending tab.

https://reviewboard.mozilla.org/r/144604/#review148678
Attachment #8873135 - Flags: review?(markh) → review+

Comment 4

5 months ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9c69d0681cd6
Close the page action menu when sending tab. r=markh

Comment 5

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9c69d0681cd6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55

Comment 6

5 months ago
I have reproduced this Bug on Nightly 55.0a1 (2017-05-28)  on Windows 10, 64 Bit!

The bug's fix is now verified on latest  Nightly 55.0a1

Build ID    :	20170607030206
User Agent  : 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170607]
You need to log in before you can comment on or make changes to this bug.