If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

first run page has unstyled fx accounts login form

RESOLVED INCOMPLETE

Status

Cloud Services
Server: Firefox Accounts
RESOLVED INCOMPLETE
4 months ago
2 months ago

People

(Reporter: dietrich, Assigned: stomlinson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 months ago
Created attachment 8872234 [details]
Screen Shot 2017-05-29 at 12.26.55.png

53.0.3 (64-bit)

STR:

1. create new profile
2. wait for first-run page to load

Expected: accounts login form is styled

Actual: it is not styled
Created attachment 8872898 [details]
Screenshot of iframe

This may have been a temporary issue with the FxA server that powers the iframe on /firstrun/, but i can no longer reproduce. Please reopen if this is still an issue for you. Thanks!

Updated

4 months ago
Attachment #8872898 - Attachment is obsolete: true
https://screenshots.firefox.com/YneEzzYaMaTS2XyL/www.mozilla.org
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

4 months ago
How confident are you that this isn't happening to other new users?

I'd feel more comfortable if the criteria for closing bugs like this was more comprehensive than WFM.
(In reply to Dietrich Ayala (:dietrich) from comment #3)
> How confident are you that this isn't happening to other new users?
> 
> I'd feel more comfortable if the criteria for closing bugs like this was
> more comprehensive than WFM.

I'm following up with the FxA team to see if they had any issues over the weekend, but this is so far the only report we've had. Happy to re-open if this is still an issue for you, but we'll keep it on our radar.
(Assignee)

Comment 5

4 months ago
:dietrich - Additional info would be really helpful or else we don't have much to go on. Do you have concrete STRs, or a screenshot of the dev console when this occurred? Which version of Firefox was this? Was E10s enabled? Were any addons installed? Which locale do you have set? Which region of the world was the user in?

Moving the component to Cloud Services->Server: Firefox Accounts
Component: Pages & Content → Server: Firefox Accounts
Flags: needinfo?(dietrich)
Product: www.mozilla.org → Cloud Services
Version: Production → unspecified
(Assignee)

Comment 6

4 months ago
Re-opening until we have a better idea of what happened.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

4 months ago
Assignee: nobody → stomlinson
Sorry if i prematurely closed this, thanks :stomlinson
(Reporter)

Comment 8

4 months ago
Heh, yeah I had a heck of a time figuring out where to even file bugs for this area in Bugzilla, so number-of-reports as a metric for size-of-problem might not work out well.

* The version info is in comment #0.

* The concrete STR are exactly as comment #0 says. That's all I did, other than a sanity check that all other internet stuff was working fine.

* Sorry, no console dump or anything else. I was testing something else and thought I'd report this since I saw it.

* E10s is always on now, right?

* I am in the Hong Kong location of the world. One of Asia's trans-pacific cable endpoints, so fantastic internet. That said, this is the internet... there always could've been a network failure.

* Full debug info from about:support: https://pastebin.mozilla.org/9023135


Maybe worth looking into detecting FOUC and adding to telemetry or whatever logging y'all do, as a future-defensive understanding of how severe the problem is.
Flags: needinfo?(dietrich)
:dietrich, can you verify if this is is still an issue for you, or can you no longer reproduce?
(Reporter)

Comment 10

4 months ago
No, I just tried and couldn't reproduce. Interestingly, the iframe took at least 5 full seconds to load, while the containing page loaded almost instantly. All other internet services working speedily, in comparison.
(Reporter)

Comment 11

4 months ago
Tried 53 first run page today and boom, I get unstyled content.

Also saying I need cookies* and localstorage enabled. I do have both enabled and am not in PB mode.




(* I do have tracking protection enabled and 3rd party cookies only allowed for visited sites.)
(Reporter)

Comment 12

4 months ago
Created attachment 8873275 [details]
Screen Shot 2017-06-01 at 10.34.53.png
(Reporter)

Comment 13

4 months ago
Oops, more info: This time I loaded the page in Nightly, while looking at bug 1368402. I'm seeing crazy slow loading times of the iframe... maybe these things are related?

https://www.mozilla.org/en-US/firefox/53.0.3/firstrun/
Please reopen if anyone has more information on this issue
Status: REOPENED → RESOLVED
Last Resolved: 4 months ago2 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.