abDirTreeHeader does not longer work in userChrome.css

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: nmm, Unassigned)

Tracking

52 Branch
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

i use abDirTreeHeader  in userChrome.css as follows:

#folderPaneHeader, #abDirTreeHeader {
  display: -moz-box !important;
}

to show ans use the <> Buttons in folderPaneHeader to change quckly the folder-view.
Since upodate 52.1.1 it does not longer work.

(other tings in userChrome.css are still working , for instance:
listitem, treechildren::-moz-tree-row {
min-height: 19px !important;
height: 19px !important;
}

treechildren::-moz-tree-indentation {
  width: 18px !important;
}
)


Actual results:

#folderPaneHeader, #abDirTreeHeader {
  display: -moz-box !important;
}
in userChrome.css is ignored


Expected results:

The DirTree Selector should appear in folderPaneHeader
(Reporter)

Updated

a year ago
Severity: normal → major
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

a year ago
Yes, this undocumented feature stopped working since we implemented another way for the folder view selection, see bug 700976. The release notes
https://www.mozilla.org/en-US/thunderbird/52.0/releasenotes/
say: New: Folder pane toolbar and folder view selector (replacement for folder view arrows).
Also see: https://support.mozilla.org/en-US/kb/new-thunderbird-52

Please remove the CSS code from your userChrome.css. Please use the official way to switch folder views by enabling |View > Toolbars, enable Folder Pane Toolbar|. The folder view switcher should be displayed by default, if not, right-click and Customize and drag "Folder Views" there.

There have been complaints about the arrows no longer working in bug 1364791, and apparently whoever wants the arrows back can use an add-on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Updated

a year ago
Resolution: INVALID → WORKSFORME
(Reporter)

Comment 2

a year ago
Thank you for fast and helpful comment!
You need to log in before you can comment on or make changes to this bug.