Can't mix android-api-15 (platform) and android-lint (job) in one try syntax

RESOLVED DUPLICATE of bug 1368733

Status

Taskcluster
Task Configuration
RESOLVED DUPLICATE of bug 1368733
5 months ago
5 months ago

People

(Reporter: tyu, Unassigned)

Tracking

Details

(Reporter)

Description

5 months ago
Our team used to utilize the try syntax:

`try: -b do -p android-lint,android-x86,android-test,android-api-15 -u robocop -t none`

(Ref: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a5695c49f80b544d2b4597dae776521f583f14ad )

to cover most of our tests. (Note: The android-lint,android-test part is actually not necessary in old implementation)

With Bug 1345863 this is changed. Some workarounds are removed so based on this context the best bet we could go for is: 

`try: -b do -p android-x86,android-api-15 -j android-lint,android-test -u robocop -t none`

(Ref: https://treeherder.mozilla.org/#/jobs?repo=try&revision=949d6bf392cf89f101406e591e3ae4e7e962df8e )

This does not work however. After a short discussion with :dustin, seems like the -p and -j syntax don't go along well with current implementation

See: `taskcluster/taskgraph/try_option_syntax.py`:

554     def task_matches(self, attributes):
555         attr = attributes.get
...
587         job_try_name = attr('job_try_name')
588         if job_try_name:
589             if self.jobs is None or job_try_name in self.jobs:
590                 if self.platforms is None or
attr('build_platform') in self.platforms:
591                     return True

Since the android-lint job is not platform specific, we will not be able to run it if we specified specific platforms for this try.
My thought was to ignore `-p` for tasks that have a job_try_name attribute but no build_platform attribute.  Greg, does that seem reasonable?
Flags: needinfo?(gps)
Bug 1368733 does exactly what I'm suggesting, so I'll dupe this one over there.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(gps)
Resolution: --- → DUPLICATE
Duplicate of bug: 1368733
You need to log in before you can comment on or make changes to this bug.