about:config javascript errors

VERIFIED DUPLICATE of bug 137697

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 137697
16 years ago
13 years ago

People

(Reporter: smaug, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020410
BuildID:    2002041003

When using about:config I get a lot of errormessages.
Error: [Exception... "'JavaScript component does not have a method named:
"getImageSrc"' when calling method: [nsITreeView::getImageSrc]"  nsresult:
"0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location:
"<unknown>"  data: no]

Reproducible: Always
Steps to Reproduce:
1. load url about:config
sspitzer@netscape.com has other about:config bugs too.
Assignee: ben → sspitzer

Comment 2

16 years ago
Confirming on 2002041003/Win2K.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
The fix is trivial.
Add the following method to
content/global/config.js line 99:
getImageSrc: function(row, colID){}

Comment 4

16 years ago
No problem for me ! 

2002041011 - WinXP.

Comment 5

16 years ago
yeah, I forgot to add it there.

*** This bug has been marked as a duplicate of 137697 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.